1

Perhaps my question is related to this one.

I use to use the English US International Keyboard with Alt-Gr Dead Keys (as far as I remember. This layout allowed me to write é by pressing R-Alt+' and then e.

I migrated to EOS Luna and now, no matter what English US International keyboard I may use, R-Alt+' prints ' and to get é I need to press R-Alt+e.

Has the layout changed? Is it a bug in EOS? Or do I need another layout?

Here below are the various layouts under English US available on eOS: enter image description here

xev, on pressing AltGr+ ' returns:

KeyPress event, serial 29, synthetic NO, window 0x3600001,
    root 0xac, subw 0x0, time 22275171, (752,335), root:(753,407),
    state 0x0, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 32, synthetic NO, window 0x3600001,
    root 0xac, subw 0x0, time 22275456, (752,335), root:(753,407),
    state 0x80, keycode 48 (keysym 0x27, apostrophe), same_screen YES,
    XLookupString gives 1 bytes: (27) "'"
    XmbLookupString gives 1 bytes: (27) "'"
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x3600001,
    root 0xac, subw 0x0, time 22275527, (752,335), root:(753,407),
    state 0x80, keycode 48 (keysym 0x27, apostrophe), same_screen YES,
    XLookupString gives 1 bytes: (27) "'"
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x3600001,
    root 0xac, subw 0x0, time 22275566, (752,335), root:(753,407),
    state 0x80, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
  • How did you select your keyboard layout? What were the other choices? Run xev; what keysyms appear when you press RAlt+'? – Gilles 'SO- stop being evil' Oct 3 '13 at 22:41
  • Keyboard selected with System Settings > Keyboard > Layout – Benjamin Oct 4 '13 at 1:23
1

The issue is not with the keyboard layout itself, but with the "test your keyboard layout" area which does not use the selected keyboard layout in the layout lists but the globally selected layout in the layout-switcher indicator on the panel.

On the screenshot below, the keyboard layout on the panel shows "en", while the third layout is selected in the settings. The test area applies the layout indicated in the panel. If this layout it switched to the third layout, it will show "en3" instead.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.