2

I've had a CentOS 6.3 VM set up for some time now, but I'm not seeing any updates when I run yum check-update, or yum list-security. There has to be something (especially with Apache/MySQL!).

If I run yum list --security or --bugfix, I do see quite a few packages, but I know many of them don't apply as they're not installed. When running yum check-update --security, again I get

No packages needed for security; 0 packages available

Now, perhaps there aren't any, but that doesn't seem plausible.

  • The yum repositories that your system uses could be relevant. – terdon Oct 2 '13 at 17:55
  • Sure! CentOS-6 - Base; CentOS-6 Extras; CentOS-6 - openlogic packages for x86_64; CentOS-6 - Updates. Let me know if you need further details. – Trevor Seward Oct 2 '13 at 17:57
  • Looking at my -Base, it points to olcentgbl.trafficmanager.net, but when I do a dig on that, 4.2.2.2 doesn't resolve it to an IP. How can I correctly update the CentOS-Base.repo file? – Trevor Seward Oct 2 '13 at 18:00
  • 1
    Please edit your question to add new information, it gets lost very easily in the comments. Show us the contents of your repo file and mention any tests you have run. – terdon Oct 2 '13 at 18:02
1

Double check that you're able to access the servers hosting the yum repositories. You can use the yum-config-manager to get the HTTP addresses like so:

$ yum-config-manager |grep "mirrorlist.*http"
mirrorlist = http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os
mirrorlist = https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=x86_64
mirrorlist = http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=extras
mirrorlist = http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=updates

Then ping the servers to make sure they're accessible to your server:

$ ping -c 4 mirrorlist.centos.org
PING mirrorlist.centos.org (72.232.223.58) 56(84) bytes of data.
64 bytes from 58.223.232.72.static.reverse.ltdomains.com (72.232.223.58): icmp_seq=1 ttl=52 time=48.5 ms
64 bytes from 58.223.232.72.static.reverse.ltdomains.com (72.232.223.58): icmp_seq=2 ttl=52 time=42.8 ms
64 bytes from 58.223.232.72.static.reverse.ltdomains.com (72.232.223.58): icmp_seq=3 ttl=52 time=47.7 ms
64 bytes from 58.223.232.72.static.reverse.ltdomains.com (72.232.223.58): icmp_seq=4 ttl=52 time=46.9 ms

--- mirrorlist.centos.org ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3053ms
rtt min/avg/max/mdev = 42.855/46.531/48.596/2.202 ms
| improve this answer | |
  • Alright, my CentOS-Base.repo wasn't correct, I had no mirrorlist= entries (only baseurl=). I found the defaults elsewhere, updated and am good to go. I see updates, now. – Trevor Seward Oct 3 '13 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.