0

I am trying to run the following two commands...

LD_LIBRARY_PATH =/opt/oracle/instantclient_12_1
export LD_LIBRARY_PATH

But when I run the first command I get an error

-bash: LD_LIBRARY_PATH: command not found

My OS data is below,

  • OS Version = CentOS release 5.9 (Final)
  • Platform Data = 2.6.18-348.18.1.el5 x86_64 x86_64 GNU/Linux

I've tried as a normal user and as sudo, also get the same error when trying to just set LIBRARY_PATH. This works on ubuntu what I am doing wrong?

2
  • 4
    Am seeing a space there???
    – 41754
    Oct 2, 2013 at 16:08
  • @uprego may as well post that as an answer, just point out that there should be no space between the variable name and the =.
    – terdon
    Oct 2, 2013 at 16:09

1 Answer 1

5

It is needed to wipe the space before the equal glyph (the =) to get the environment variable set.

3
  • et tu spacebar? Thanks working now.
    – HelloWorld
    Oct 2, 2013 at 16:23
  • And btw if you put the space after the equal glyph, you unset (am not sure about the inside mechanics) that variable.
    – 41754
    Oct 2, 2013 at 16:23
  • And then you make the command interpreter try to run /opt/oracle/instantclient_12_1, what looks like a symlink to a shared object file.
    – 41754
    Oct 2, 2013 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .