I have an old HP DL380 G4 server that I'm trying to load Arch Linux onto, but I've run into a bit of a snag. I went all the way through this guide, and everything seemed to go smoothly, but when I reboot into the actual system itself (as opposed to a chroot from the disk), I get a brief flash of a screen that says "welcome to grub", then the monitor gives me "cannot display this video mode".

The monitor is an old Dell 1280x1024 monitor connected by VGA. I tried with another old monitor, and it gave me an out of range error. The thing is that the disk worked fine with the monitor, even the graphical Arch selection screen was displayed properly. I have done some research and tried a few things:

  • I added nomodeset to the kernel config line in /etc/default/grub

  • I added i915.modeset=0

  • I installed X and ran startx from chroot, but then the display error happened immediately.


I've had partial success by looking up the monitor config and entering it manually into the xorg.conf file. Also, I changed to the mach64 driver, and now there's no monitor error, just a black screen when I run startx. However, when I try to boot to the disk itself, instead of the Arch DVD, I still get the "can't display this video mode" error. So it would seem that the two errors do not have the same cause.

  • What video card are you using?
    – jasonwryan
    Commented Oct 1, 2013 at 17:10
  • @jasonwryan Just the built in card. "lspci | grep VGA" says that it's AMD/ATI, so I'm using the xf86-video-ati driver. Commented Oct 1, 2013 at 19:31
  • You could try removing your xorg.conf as per the wiki...
    – jasonwryan
    Commented Oct 1, 2013 at 20:18
  • Does the problem exist at boot time or when you startx ? i915 is for intel cards so i915.nomodeset has no effect for your AMD/ATI Card. Can you paste the result of lspci | grep VGA ? We need to know if your card support KMS which is now enabled by default in rencent kernel.
    – Mali
    Commented Oct 2, 2013 at 8:54
  • lspci | grep VGA tells me that it's an ATI Rage XL card. The only way I've gotten into a terminal is chrooting from the install dvd. When I boot into the actual hard drive, there's brief flash of "welcome to GRUB" then the monitor gives the error. Now, when I chroot and execute startx, there's no error, but the screen is blank. Do you know, does arch automatically boot into runlevel 3 or 5? I'm guessing 3 since X wasn't installed until I ran pacman -S x-server.... I've been trying to enable SSH, but I get a "connection refused". Can I do systemctl enable while chrooted from the disk? Commented Oct 2, 2013 at 13:52

1 Answer 1


GRUB allows you to choose the VGA definition it uses when booting. (Note: this does not affect the definition in Xorg).

You need to add the option vga=xxx on the kernel stanza in the file /boot/grub/menu.lst.

Of course, replace xxx with the video mode you want. Your kernel stanza will look like this: kernel /boot/vmlinuz-2.6.18-6-686 root=/dev/sda7 ro vga=791

Here is a list of the available video modes:

Colour depth    640x480     800x600     1024x768    1280x1024   
8 (256)         769         771         773     775     
15 (32K)        784         787         790     793     
16 (65K)        785         788         791     794 
24 (16M)        786         789         792     795     

so vga=794 seems a good choice for your configuration

  • Where did you get that list of modes?
    – terdon
    Commented Oct 1, 2013 at 15:54
  • Apparently, menu.lst is deprecated, so I appended vga=794 to the end of the kernel config line in /etc/default/grub, but unfortunately, no dice. I think the problem may be an insufficiently configured xorg.conf file. Here's mine. I think the issue is that there's no horizontal or vertical sync rate. Would that cause an issue like this? Commented Oct 1, 2013 at 18:34
  • @terdon: you can find it here for example : en.wikipedia.org/wiki/…
    – Mali
    Commented Oct 2, 2013 at 8:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .