On my computer running Debian squeeze with the radeon driver, the XVideo extension doesn't work (the extension itself is there but the hardware is not supported). xvinfo shows

X-Video Extension version 2.2
screen #0
 no adaptors present

The adapter is a Gigabyte Radeon X1650, shown by lspci as

01:00.0 VGA compatible controller: ATI Technologies Inc RV535 [Radeon X1650 Series] (rev 9e)

The kernel driver is loaded, as lsmod | grep radeon shows:

radeon                574044  1 
ttm                    40018  1 radeon
drm_kms_helper         20065  1 radeon
drm                   142391  3 radeon,ttm,drm_kms_helper
i2c_algo_bit            4225  1 radeon
i2c_core               15712  6 eeprom,radeon,drm_kms_helper,drm,i2c_algo_bit,i2c_i801

The required (?) (non-free) firmware also seems to be loaded. From my kernel logs:

Mar 14 18:59:33 darkstar kernel: [   11.883832] [drm] Loading R500 Microcode
Mar 14 18:59:33 darkstar kernel: [   11.883834] platform radeon_cp.0: firmware: requesting radeon/R520_cp.bin

XVideo worked under Debian lenny. After upgrading to squeeze (Linux kernel: 2.6.32-5-vserver-amd64; xserver-xorg-video-ati 6.13.1-2+squeeze1) it doesn't. How do I get it back?

(link to the X server logs)

  • Maybe see if removing the free driver (xserver-xorg-video-ati) and the drivers it depends on works. – tshepang Mar 16 '11 at 6:38
  • Have a look at your kernel config (/boot/config-2.6.32...) to see if has all of these. – tshepang Mar 16 '11 at 6:44
  • @Tshepang: I am using the stock Debian kernel, so it has the required pieces (and as I show the radeon module is loaded). How is removing the driver supposed to help? – Gilles 'SO- stop being evil' Mar 16 '11 at 8:24
  • @Gilles: This is a guess, but maybe when it's present, it's used, instead of the proprietary one. – tshepang Mar 16 '11 at 8:57
  • 1
    You considered filing a bug? – tshepang Mar 17 '11 at 22:25

I dealt with this recently; it was a real pain, and unfortunately I don't have notes on exactly what I did.

I saved these two links:

Recent radeon chips don't have dedicated video overlay hardware, they use the texturing support in the 3D core to emulate a video overlay. This means that 3D acceleration needs to be working for the video overlay to work. In my glxinfo I have:

OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (RV515 7145) 20090101  TCL DRI2

If you used the fglrx driver in the past, make sure that any remnants of it are removed (remove any packages found by dpkg -l '*fglrx*' and check for kernel modules in /lib/modules.

I currently have radeon in /etc/modules, as suggested at one of the links above, but I'm not sure if it's strictly necessary. There's nothing interesting in my xorg.conf.

Good luck!

| improve this answer | |
  • As far as I can tell, the problems mentioned in the two links you cite were solved by the time squeeze was released. I already have radeon in /etc/modules, it is loaded with modeset=1, I have radeon kernel modesetting enabled in my kernel logs and Loading extension DRI2 (but no other occurrence of DRI2) in my X logs. However glxinfo shows Mesa X11 as the renderer, not Mesa DRI; I have libgl1-mesa-swx11 installed, not libgl1-mesa-glx. – Gilles 'SO- stop being evil' Mar 24 '11 at 22:23
  • There is also some info at x.org/wiki/radeonBuildHowTo. libgl1-mesa-swx11 is probably not right. Do you have anything in the log for "textured video" or plain "dri"? – Andy Mar 25 '11 at 0:34
  • After removing the fglrx-glx and fglrx-driver packages (which were supposedly not used, I saw no trace in any log) and installing libgl1-mesa-glx in place of libgl1-mesa-swx11, XVideo works. Thank you! – Gilles 'SO- stop being evil' Mar 25 '11 at 22:46

I'm not sure if this will help, but I found this post:

Where the author seems to have fixed the problem, and several of the commenters claim it fixed it for them as well.

| improve this answer | |
  • “The following is using the fglrx ATI proprietary drivers and ONLY applies to these drivers.” So it's irrelevant for this question, I'm using the open source radeon driver (which worked under lenny). – Gilles 'SO- stop being evil' Mar 18 '11 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.