0

I am facing memory/data segment issues while running git. However, if I set my ulimits to a bit higher like below.

ulimit -m 262144

ulimit -d 262144

It runs fine. Don't we have anyway to allocate more memory/data segment while running git commands.

  • By default those should be unlimited, so perhaps you are on a system where limits have been configured. You could just add ulimit -m unlimited & ulimit -d unlimited to ~/.profile and/or ~/.bashrc. – goldilocks Sep 30 '13 at 15:58
  • yeah..but I want more is to run git with some memory options. I'll be playing with system security stuffs if I set parameters to unlimited. – Ahmad Sep 30 '13 at 16:10
  • 3
    Limiting (or not limiting) those particular fields is not really a security issue. If the administration really does not want you to exceed a certain value, it will have a hard limit set, and you need superuser permissions to change that. – goldilocks Sep 30 '13 at 16:24
4

/etc/security/limits.conf will do exactly what you want. It can limit just a single program name, thus will not impact 'global' settings the way ulimit will.

Run the manpage: man limits.conf

  • This is a great answer. But doesn't solve my problem as I don't have access to /etc/security folder. – Ahmad Oct 1 '13 at 8:37
  • Make a request of the system admin to put the entry in for you. It's okay if an admin has to do work now and then ;-) – Andrew Oct 1 '13 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.