3

I'm trying to find here a solution for my long-time touchpad problem.

I tried one year ago at http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/touchpad-not-beign-recognized-probably-the-kernel-doesn%27t-load-it-918152/

I copy the question:


I have a laptop SONY VAIO VGN-NS21Z with a touchpad that is not beign loaded with the kernel. (Not appears at the Xorg log nor xinput list)

My touchpad has not a function key to activate it or disabling it so that is not the problem.

I've tried enabling i8042 parameters at kernel options as seen googling it and it doesn't work.

Before someone asks yes, the touchpad works at my Windows 7 partition. This is what I've got from the device properties at Windows 7.

NOTE: Titles are translated by me so may do not match with the Windows7 English version ones.

Hardware ID:
    ACPI\SNY9008
    *SNY9008
Compatible ID
    *PNP0F13
Service
    i8042prt
Name of device physic objet
    \Device\0000005d
Access path to the instance of the device
    ACPI\SNY9008\4&3290F976&0
Primary
    PCI\VEN_8086&DEV_2919&SUBSYS_9045104D&REV_03\3&11583659&0&F8
Brothers
ACPI\PNP0200\4&3290f976&0
ACPI\INT0800\4&3290f976&0
ACPI\PNP0103\4&3290f976&0
ACPI\PNP0000\4&3290f976&0
ACPI\PNP0C04\4&3290f976&0
ACPI\PNP0C02\2
ACPI\PNP0B00\4&3290f976&0
ACPI\PNP0100\4&3290f976&0
ACPI\PNP0303\4&3290f976&0
ACPI\PNP0C09\4&3290f976&0
ACPI\SNY5001\4&3290f976&0
Node secure name of the controller
    msmouse.inf:MSMfg.NTamd64:PS2_Inst:6.1.7600.16385:*pnp0f13
Id of the matching device
    *pnp0f13

From that details I've found at the dmesg something related to PNP0F13 and SNY9008 which seems to be related to the touchpad as seen at Windows details:

As I can see I think that the kernel detects the touchpad but when it has to assign it to wherever it has to be assigned to work it confounds the touchpad with the keyboard or whatever and then I have the keyboard "mounted" two times.

$ dmesg | grep PNP0f13
[    0.882985] pnp 00:08: Plug and Play ACPI device, IDs SNY9008 PNP0f13 (active)
[    1.776101] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
$ dmesg | grep i8042
[    1.776101] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    1.825321] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.846471] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2

I've checked the ioports and it suggest me that I'm correct. You can see that I have two ports exactly at 0x60 and 0x64 at ioports that are a keyboard (maybe it is normal but I don't know). If we assume that SNY9008 PNP0F13 is the touchpad (Which I think it is as seen on Windows 7) that is the problem.

/proc/ioports

0000-0cf7 : PCI Bus 0000:00
  0000-001f : dma1
  0020-0021 : pic1
  0040-0043 : timer0
  0050-0053 : timer1
  0060-0060 : keyboard
  0062-0062 : EC data
  0064-0064 : keyboard
  0066-0066 : EC cmd
  0070-0077 : rtc0
  0080-008f : dma page reg
  00a0-00a1 : pic2
  00c0-00df : dma2
  00f0-00ff : fpu
  03c0-03df : vga+
  0400-047f : pnp 00:05
    0400-0403 : ACPI PM1a_EVT_BLK
    0404-0405 : ACPI PM1a_CNT_BLK
    0408-040b : ACPI PM_TMR
    0410-0415 : ACPI CPU throttle
    0420-042f : ACPI GPE0_BLK
    0430-0433 : iTCO_wdt
    0450-0450 : ACPI PM2_CNT_BLK
    0460-047f : iTCO_wdt
  0500-053f : pnp 00:05
  0680-069f : pnp 00:05
  0800-0803 : pnp 00:05
0cf8-0cff : PCI conf1
0d00-ffff : PCI Bus 0000:00
  1000-100f : pnp 00:05
  164e-164f : pnp 00:05
  a000-afff : PCI Bus 0000:05
  b000-bfff : PCI Bus 0000:03
  c000-cfff : PCI Bus 0000:02
    c000-c0ff : 0000:02:00.0
      c000-c0ff : sky2
  d000-dfff : PCI Bus 0000:01
    d000-d0ff : 0000:01:00.0
  e000-e01f : 0000:00:1f.3
    e000-e01f : i801_smbus
  e020-e03f : 0000:00:1f.2
    e020-e03f : ahci
  e040-e05f : 0000:00:1d.2
    e040-e05f : uhci_hcd
  e060-e07f : 0000:00:1d.1
    e060-e07f : uhci_hcd
  e080-e09f : 0000:00:1d.0
    e080-e09f : uhci_hcd
  e0a0-e0bf : 0000:00:1a.2
    e0a0-e0bf : uhci_hcd
  e0c0-e0df : 0000:00:1a.1
    e0c0-e0df : uhci_hcd
  e0e0-e0ff : 0000:00:1a.0
    e0e0-e0ff : uhci_hcd
  e100-e103 : 0000:00:1f.2
    e100-e103 : ahci
  e110-e117 : 0000:00:1f.2
    e110-e117 : ahci
  e120-e123 : 0000:00:1f.2
    e120-e123 : ahci
  e130-e137 : 0000:00:1f.2
    e130-e137 : ahci

Using: Fedora 16 KDE Spin kernel 3.1.4-1.fc16.i686.PAE Now 3.1.9-1.fc16.i686.PAE


Note that now I'm using Linux mint 13: Linux 3.2.0-54-generic #82-Ubuntu SMP Tue Sep 10 20:08:42 UTC 2013 x86_64 But the problem is the same.

Note: I'm just a linux user, not a sysadmin, so please be specific when asking something.

If more information is needed please ask me and I'll post it. Thank you.

  • it might be interesting to know the laptop model you are using (or have i missed it?) – umläute Sep 30 '13 at 14:19
  • Please also mention your laptop make and model, it can help us search. Did you try to use gpm as suggested in your other question? What happens if you sudo modprobe psmouse? – terdon Sep 30 '13 at 14:20
  • Sorry I forgot about it. It is SONY VAIO VGN-NS21Z. I tried to use gpm today but I don't understand how to use it very well. I've just executed sudo modprobe psmouse and it does nothing. Please if you can explain how to use the gpm command i would try. Thank you. – Jorge Sep 30 '13 at 14:34
  • Googling for that model + "linux" yields a few people with minor problems -- but not this one, and if not being able to control the backlight is an issue for someone, you'd think they'd say so if the mouse didn't work either. I don't think it actually matters for this, but does lsmod | grep sony show the sony_laptop module? – goldilocks Sep 30 '13 at 14:58
  • Yes, and the backlight works. lsmod | grep sony sony_laptop 45393 0 – Jorge Sep 30 '13 at 15:03
0

I have the keyboard "mounted" two times.

That's not the way I would read your dmesg output. The keyboard is reported once by the serio module and then once by the input module. One deals with the keyboard as a hardware device and the other interprets information from the former to implement a connected keyboard. They work together.

maybe it is normal but I don't know

Probably, since I'm on a standard desktop with no touchpad and I get the same thing:

> dmesg | grep i8042
[    1.301505] i8042: PNP: No PS/2 controller found. Probing ports directly.
[    1.304381] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.305095] serio: i8042 AUX port at 0x60,0x64 irq 12

> cat /proc/ioports
0000-0cf7 : PCI Bus 0000:00
  0000-001f : dma1
  0020-0021 : pic1
  0040-0043 : timer0
  0050-0053 : timer1
  0060-0060 : keyboard
  0062-0062 : EC data
  0064-0064 : keyboard

Notice "keyboard" is reported at the same two addresses as yours.

Not appears at the Xorg log nor xinput list

It could be just a matter of missing Xorg drivers, but it seems weird this would happen with two different distros. None-the-less, you might check that the xorg-x11-drv-synaptics package is installed (that's the fedora name; on mint I guess you should be able to find it with apt-cache search synaptics). Synaptics make pretty much all touchpads, AFAIK, and yours seems to use a Synaptics driver on Windows.

Do you get anything from dmesg | grep mouse?

  • Thanks for the clarification, as you can see I know nothing about the kernel nor linux drivers. Yes, I had the synaptics drivers installed in that time and now that I'm using Linux Mint 13 (KDE) I have installed xserver-xorg-input-synaptics too. dmesg | grep mouse [ 0.953397] mousedev: PS/2 mouse device common for all mice – Jorge Sep 30 '13 at 14:44
  • That's what I get for mouse too. I guess it does not prove that it's actually found one... – goldilocks Sep 30 '13 at 14:53
  • Keep in mind that I have the laser one connected too. – Jorge Sep 30 '13 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.