2

Bellow are the steps I undertook to try to disable thumbnails in Nautilus ( following instruction mentioned here: https://wiki.gnome.org/dconf/SystemAdministrators ) . It didn't help. (I'm on Debian Wheezy, which seemingly has no /etc/dconf by default):

  • mkdir -p /etc/dconf/db/local.d/locks

  • nano /etc/dconf/db/local.d/settings

    # /etc/dconf/db/local.d/settings
    # prevent showing thumbnails
    [org.gnome.nautilus.preferences]
    show-image-thumbnails="never"
    
  • nano /etc/dconf/db/local.d/locks/settings

    # prevent changes to showing thumbnails setting
    org.gnome.nautilus.preferences.show-image-thumbnails
    
  • mkdir /etc/dconf/profile

  • nano /etc/dconf/profile/local

    system-db:local
    
  • export DCONF_PROFILE=/etc/dconf/profile

  • dconf update

What's wrong here?

I also tried to disable it using dconf-editor (both as root and as regular user) and I was not able to change the setting from 'local-only' to 'never' it looked like it was locked.

I also tried gsettings:

# gsettings get org.gnome.nautilus.preferences show-image-thumbnails 'local-only'

# gsettings set org.gnome.nautilus.preferences show-image-thumbnails "never"

** (process:5834): WARNING **: The connection is closed

** (process:5834): WARNING **: The connection is closed

PS: I didn't reboot. Do I need to reboot in order for the new settings to take effect?

I found several dconf files but it doesn't look like they contain any lock of org.gnome.nautilus.preferences.show-image-thumbnails and adding

[org.gnome.nautilus.preferences]
show-image-thumbnails="never"

to them didn't help either. Here are they:

/var/lib/gdm3/.cache/dconf
/var/lib/gdm3/.cache/dconf/user
/var/lib/gdm3/dconf/db
/var/lib/gdm3/dconf/profile
/var/lib/gdm3/dconf/db/gdm
/var/lib/gdm3/dconf/db/gdm.d
/var/lib/gdm3/dconf/db/gdm.d/00-upstream-settings
/var/lib/gdm3/dconf/db/gdm.d/10-desktop-base-settings
/var/lib/gdm3/dconf/db/gdm.d/90-debian-settings
/var/lib/gdm3/dconf/db/gdm.d/locks
/var/lib/gdm3/dconf/db/gdm.d/locks/00-upstream-settings-locks
/var/lib/gdm3/dconf/profile/gdm

and

/usr/share/gdm/dconf
/usr/share/gdm/dconf-profile
/usr/share/gdm/dconf/00-upstream-settings
/usr/share/gdm/dconf/10-desktop-base-settings
/usr/share/gdm/dconf/locks
/usr/share/gdm/dconf/locks/00-upstream-settings-locks

It looks like dconf update ignores:

/etc/dconf/db/local.d/settings

because if I intentionally write wrong things there it doesn't complain.

Any ideas?

  • 1
    I'm not sure whether it's needed but you should at least restart Gnome if not the computer just to make sure that makes no difference. – terdon Sep 29 '13 at 15:01
1

I think this is the same subtle issue I stumbled over for a while... Look at the dconf(7) man page carefully.

You're trying to set DCONF_PROFILE to a directory, not to a file. Really, this isn't necessary, since effectively DCONF_PROFILE defaults to user, so just name the file /etc/dconf/profile/user to ensure it gets read:

 # cat /etc/dconf/profile/user 
 user-db:user
 system-db:local
 # 

As long as dconf update does generate a /etc/dconf/db/local file (from whatever is in /etc/dconf/db/local.d/), then this should all take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.