5

I have an Arch Linux install in a VirtualBox VM, and as I'm working all of a sudden, it will lose its dynamic IP address.

When this happens, if I check on the status of the dhcpcd service, it says it's running.

$ systemctl status dhcpcd.service
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service: enabled)
   Active: active (running) since Sat 2013-09-28 20:10:32 EDT; 49min ago
 Main PID: 166 (dhcpcd)

I can try to restart the service, but it does not establish an IP.

$ sudo systemctl restart dhcpcd.service
**No output is returned from the command*

I can set an address manually, and it will work for a while, but then it'll drop again after a few minutes.

$ sudo ifconfig enp0s3 10.0.0.109 netmask 255.255.255.0 up
$ sudo route add default gw 10.0.0.1

I can also run dhcpcd manually, and it will successfully get an IP address, but again it will drop after a few minutes.

$ sudo dhcpcd enp0s3
dhcpcd[2580]: sending commands to master dhcpcd process

I have tried disabling dhcpcd.service and using [email protected], but it has the same results. Any ideas?

6
  • You don't have another network manager running, do you?
    – jasonwryan
    Sep 29, 2013 at 1:28
  • @jasonwryan, no. Sep 29, 2013 at 1:32
  • I'd use dhclient instead. I experienced lots of problems with dhcpcd on Gentoo lately. Probably they appeared after update, however it didn't work well until I changed the client app. Oct 5, 2013 at 0:47
  • 1
    dhcpcd on arch linux behaves a bit differently from other distros. For example, it spawns its own wpa_supplicant, and it probably does something similar for wired connections. I would look carefully at the source, I believe there is an argument you can pass to dhcpcd to make it behave normally
    – pepper
    Jun 13, 2014 at 21:05
  • Can you post the dmesg | tail output when this happens?
    – Braiam
    Dec 26, 2015 at 1:29

1 Answer 1

1

I just experienced the same problem and worked around it by installing an older version of dhcpcd. the latest version that seems to work is 5.6.8-1

Maybe try manually compiling the package? or disabling dhcpcd entirely and just configuring your VM ip statically.

Not the answer you're looking for? Browse other questions tagged .