4

I'd like to temporarily disable autofs on my fedora 19 x86 install. I would like to insert USB drives without them auto-mounting. Typing:

service autofs stop

Returns:

Redirecting to /bin/systemctl stop  autofs.service
Failed to issue method call: Unit autofs.service not loaded.

Typing:

chkconfig autofs off

Returns: error reading information on service autofs: No such file or directory

I see there are ways to stop it from running at startup, but I want it to load at startup. I need to be able to stop & start it without logout/reboot.

1

To stop autofs:

$ sudo service autofs stop

To stop it permanently:

$ sudo chkconfig autofs off

However, I do not believe the automounting service autofs is what's mouting the USB drives, rather they're done by GNOME.

If you bring up Nautilus you can access the dialog to change this. It's in the menu Edit -> Preferences, under the Media tab. From this tab you can control various aspects of automounting of CD, DVD, and USB, etc.

  • Unfortunately, like I said in my post, running those commands, as root, does not stop or start the service. – hotkarl Sep 27 '13 at 18:05
  • 2
    @hotkarl - I think you missed my point. The automatic mounting of USB drives is done by a different system that's part of GNOME. The autofs service is for mounting directories typically from a samba or NFS share. It can mount other things, but is generally not used for this. – slm Sep 27 '13 at 18:07
  • Oh my bad!! I see now.. I'm actually using MATE, and don't have the USB option in that path, but I'll figure something out. Thanks!! – hotkarl Sep 27 '13 at 23:56
  • Try using the tool mateconf-editor then navigate the tree /apps/caja/preferences/media_automount. You should be able to disable it from there. – slm Sep 28 '13 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.