0

I know there are a ton of questions on this.

I have read almost all of them.

I have also googled this problem to no avail

I attempted to

git clone [email protected]:myhubname.git

and I get

Permission Denied (PublicKey,keyboard-interactive)

as a response

I have tried setting the PasswordAuthentication to yes and uncommenting it in ssh_config this didn't work

I have set the user.name and user.email to what git repo is setup for. They actually have pretty clear instructions so I am at a loss to what I am doing wrong.

I also saw an article that said modify the authorized_keys file in ssh which doesn't exist for me. I created it and it still didn't work.

6
  • Did you upload your public key to assembla? Does your private key have passphrase encryption on it? Sep 13, 2013 at 4:00
  • @Cupcake I know this needs to be done but I can't figure out how
    – AMR
    Sep 13, 2013 at 12:13
  • Which part, uploading your public key or encrypting your private key? Sep 13, 2013 at 13:06
  • @Cupcake great question. I am pretty sure I need a private key on my system. Then copy and paste that into the repo settings online
    – AMR
    Sep 13, 2013 at 18:32
  • The private key is private, it must be kept a secret and not be uploaded to a remote server that you do not control. Only public keys should be uploaded to remote server's that you want ssh access to. A private key should remain secure either on your local machine or some other secure storage device, and can then be used to authenticate yourself with a remote server that has your public key. If your private key is encrypted with a passphrase, you need to decrypt it before you can use it, with something like ssh-agent. Sep 14, 2013 at 1:27

0

You must log in to answer this question.

Browse other questions tagged .