1

I just upgraded Linux Mint Debian Edition with the up7 package.

The update manager failed initially (can't remember where...) so I ran sudo apt update, sudo apt dist-upgrade, sudo apt upgrade and sudo dpkg --configure -a.

Situation now: when I reboot and select the new kernel (3.10-2-amd64) from the grub menu, the following happens:

  • This:

early console in decompress_kernel Decompressing kernel... Parsing ELF ... done. Booting the kernel. [<...> Could not configure common clock.

  • Linux Mint splash screen appears.

  • The NVIDIA Screen appears.

  • I get this error message:

FAIL: startpar: service(s) returned failure: plymouth ... failed!

  • The system quits.

Sometimes the first message will be shown twice with a login prompt in between, after which the system will quit.

Any ideas? I will be happy to boot into the old kernel and provide any output!

1

Does sudo apt-get -f install help? Also have a look at the LMDE updates forum they seem to have screwed up with UP7, a lot of people are reporting problems. I am currently updating myself we'll see how it goes.

A common source of problems is the nvidia proprietary driver. This is compiled against your current kernel and can cause problems if the kernel changes. The normal recommendation is to remove it, then upgrade, then reinstall it.

Since you've already upgraded, I would try disabling the nvidia driver and switching to the open source nouveau. If that lets you boot, you can then reinstall the nvidia driver for your new kernel. Try these steps (adapted from here, I recommend you read that)

1.Boot into the old kernel, switch to a tty (CtrlAltF1) and log in.

  1. Stop the mdm service and edit your /etc/X11/xorg.conf to use nouveau. Depending on your setup you might not be using the xorg.conf but /etc/X11/xorg.conf.d/20-nvidia.conf. If so, delete /etc/X11/xorg.conf.d/20-nvidia.conf and create a /etc/X11/xorg.conf.d/20-nouveau.conf with these contents:

    Section "Device"
        Identifier "Nvidia card"
        Driver "nouveau"
    EndSection
    
  2. Un-blacklist nouveau. Find where you have blacklisted it (which you have almost certainly done) and comment out the appropriate line:

    $ grep nouv /etc/modprobe.d/*
    /etc/modprobe.d/nvidia-kernel-common.conf:blacklist nouveau
    

    So, on my system, I have it blacklisted in /etc/modprobe.d/nvidia-kernel-common.conf so I had to change that line to:

    #blacklist nouveau
    
  3. Reboot. If that solves things and you can now boot normally, reinstall the nvidia driver for the new kernel:

    sudo apt-get install nvidia-kernel-dkms linux-headers \ 
                 nvidia-settings nvidia-xconfig 
    sudo nvidia-xconfig
    
  • Wow, there are many people reporting problems with UP7! – trolle3000 Sep 25 '13 at 14:42
  • I think I'll check the UP forum and see if any solution appears that does not involve switching back and forth between Noveau and NVIDIA. If that really is the solution, I'd rather do a re-install. Appreciate the answer nonetheless! – trolle3000 Sep 25 '13 at 14:43
  • @trolle3000 this is not that complex actually. Just switch to nouveau once so you can boot and then reinstall the nvidia driver. You don't need to "switch back and forth" you only need to do this once. – terdon Sep 25 '13 at 14:44
  • @trolle3000 wow, I updated and had quite a bit of trouble. All sorted out now. Did you manage to boot on the nouveau driver? – terdon Sep 26 '13 at 1:40
  • haven't tried it yet;-) Did it work on your machine? – trolle3000 Sep 26 '13 at 16:55
0

I don't know Mint but I had similar issue with Fedora 18 and 19 and nvidia.

My solution may help you get answers;

In my case turned out that the akmod-nvidia driver is not compatible with kernels newer than 3.9. (So 3.10 and 3.11)

I had to download the latest NVidia driver from NVidia (325.15), patch it and then install it.

The downside is that you'll have to rebuild the driver after a kernel update until the driver package is updated in the repo.

Here's a link to the description about patching the driver. (See Troubleshooting)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.