0

I am using opensuse. I have created a directory projects under /srv and set its permissions to 770 and chown -R wwwrun:developer /srv/projects/
I have used
usermod -a -G developer username
but I can't access that directory, I always get permission denied entry.
I want to clone a git repo in projects so that only apache and group of developer able to rwx it.

4
  • 2
    You need to login again for that change to take effect Sep 25, 2013 at 9:39
  • Unless you want to serve the git repository through the web server, don't let apache access it (the .git repository storage) - too dangerous.
    – peterph
    Sep 25, 2013 at 11:17
  • Thanks. I usually do chown -R git:developer .git` and chmod 770 -R .git. is that right?
    – codescope
    Sep 26, 2013 at 23:22
  • @StephaneChazelas: Logging again worked. I also read that opening another terminal window will also do the trick.
    – codescope
    Sep 26, 2013 at 23:24

1 Answer 1

0

Try this:

(in addition to what you have done)

#chgrp -R developer /srv/projects/
1
  • Because it is already under the same group, how above statement going to make difference? opening new term or logging again worked.
    – codescope
    Sep 26, 2013 at 23:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .