2

Am trying to troubleshoot an issue that has arisen during a DR test and admit from the outset that LVMs are not my forte.

We have a RHEL6 VM running on ESXi 5.1. We are using a LUN to LUN replication to allow us to use a system called SRM to recover our VMs. There is a 3TB Logical Volume on the VM with each "physical disk" having its own hard disk and LUN created. The test recovery process takes a snapshot of the LUNs at the recovery site allowing tests to be made etc and then any changes are dumped.

All other VMs have been brought up correctly but this VM is not playing ball. The error I am receiving is:

Couldn't find device with uuid B91AAR-........
Couldn't find device with uuid zcRrvn-........

This means the LVM is missing two physical volumes so will not mount. Running "fdisk -l" I can see the two devices /dev/sdb/ and /dev/sdc/ but their is not /dev/sdb1 or /dev/sdc1. I initially thought that this meant the partition info had been trashed but running the same command on its live counterpart yielded the same result (sdb and sdc do not have a partition that fdisk is aware of). Form my understanding this is not a requirement for LVMs, though is not considered best practice for sanitys sake.

I have tried to recreate the physical disk using a restorefile and pvcreate but that states it still cannot find the physical disk. I am a bit stumped as to what to try next to try and get this working and would be grateful of any guidance someone could throw my way.

EDIT: fstab:

[root@proddossvm ~]# more /etc/fstab
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/VolGroup01/LogVol00 /PRODDOSS              ext3    defaults        0 0
  • Please add your /etc/fstab to your question. – dawud Sep 24 '13 at 13:10
  • also update output of pvs and vgs and lvs – Rahul Patil Sep 24 '13 at 17:43
  • Does ''fdisk -l'' show the partitions? – Nils Sep 24 '13 at 19:33
  • unfortunately the nature of our DR test meant I had to revert the changes and restore the normal link between the sites. I am hoping to have another crack at this this morning but an initial poke aroun actually suggests it may be a failure in SRM presenting the LUNs to the VM so fingers crossed. – Tim Alexander Sep 25 '13 at 8:55
0

As mentioned in the comments, pvs is going to be the key to figuring this one out. Next time you set out to test maybe you can grab the output.

It might be worth checking /etc/lvm/lvm.conf and looking for the "filter" listed. If it has been modified (it should be modified but often this is skipped) to ignore /dev/sdb or sdc then that would result in your exact error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.