4

I want to emulate an ARM processor for running the assembly programs using QEMU in RHEL. I have installed QEMU but I still have problems in running the assembly program. I got the assembly program, memory map and the makefile from this link. However, if I run the below command,

qemu-system-arm -S -s -M versatilepb -daemonize -m 128M -d in_asm,cpu,exec -kernel hello_world.bin ; gdb-multiarch --batch --command=hello_world.gdb

I get an error as "hello_world.bin - No such file or directory". I am not sure what is to be done to run the above command. So, I got an ARM image from this link. Instead of hello_world.bin, if I specify the kernel name as "zImage.Integrator", I am getting a QEMU console window. However, I am not able to type or do anything in that window. Can someone please let me know how to run an assembly program using QEMU for ARM?

closed as unclear what you're asking by Anthon, slm, Gilles, manatwork, Renan Sep 28 '13 at 20:29

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

Alright, I figured out what am making wrong. I should actually run the make command which will create my object file and binary file. I got more information on running the command from this link. Now, I have to figure out how to install GDB to interact between the ARM and QEMU.

  • I ran using the below commands. echo "PATH=$PATH:/opt/ARM/bin" >> /home/"$(whoami)"/.bashrc source /home/"$(whoami)"/.bashrc – Ramesh Sep 23 '13 at 17:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.