Since about 2 to 3 weeks ago, my Ubuntu 13.04 desktop frequently freezes after I am using Chrome for a while. The mouse is movable, but nothing respond to mouse or keyboard. I have to push the power button to shut down the machine and restart it. Sometimes, the symptoms are not complete freezing, but all files become read-only, which makes nothing works. All Chrome tabs shows error message. Every time I use the new version of google map in chrome, Ubuntu freezes very soon.

Though I actually never expected a browser program could freezes the whole system, now I believe the culprit is Chrome. If I don't use Chrome, say using Firefox instead, then the system runs OK. I first thought my hard disk has some errors. I tried to fix it and use disk utility to do extended smart test, and found no errors.

I also searched on Web and found people asking similar questions, without getting good solutions. Some suggest this is related to video card driver. But I've always been using Chrome on Ubuntu smoothly until 2 or 3 weeks ago.

Some information about my system:

Ubuntu 13.04
kernel version: 3.8.0-30-generic
cpu: Intel core i7 2600K (use its integrated video card)

Update: Using echo 0 | sudo dd of=/sys/module/i915/parameters/semaphores as suggested by goldilocks seemed to solve the problem at first.

The next day, problems come again:

(1) The first problem is that I cannot boot into Ubuntu, because the root partition /dev/mapper/ubuntu (a LVM partition) cannot be found. I tried several times of restart, sometimes I can get into Ubuntu, but nothing is usable, even vi a text file shows input/output error in the command. Eventually, I use recovery mode to check disk and repair packages. Then I can boot into Ubuntu as usual.

(2) However, Chrome freezes Ubuntu again. The initial symptoms described in the beginning of the post come back. The command echo 0 | sudo dd of=/sys/module/i915/parameters/semaphores seems only extend the time when Chrome works OK. However, eventually, after half or one hour, the system will freeze or everything become read-only again. If I use Google map, then several minutes later, the system will freeze. Then I have to shut down the machine by brute force. After I reboot into Ubuntu, the content of the file /sys/module/i915/parameters/semaphores is changed back to "-1", instead of "0" I've written before. Using grep i915_hangcheck_hung /var/log/* didn't find relevant errors for the crashing time. I also suspect the problem is related to the flash plugin in Chrome, so I switched the flash plugin from adobe's to the Chrome built-in one. But the problem remains.

So I am not certain this is 100% due to Chrome now. For now, I'll use Firefox, and see if the system is stable.

  • 'After I reboot into Ubuntu, the content of the file /sys/module/i915/parameters/semaphores is changed back to "-1", instead of "0" I've written before.' I've added a paragraph to the end of my answer explaining why that is.
    – goldilocks
    Commented Sep 24, 2013 at 1:37
  • I'm having the same issue while using chrome.
    – Khaleel
    Commented Dec 10, 2013 at 4:08
  • my advise would to use chromium ?
    – Kiwy
    Commented Mar 13, 2014 at 8:47

1 Answer 1


You are presumably using the i915 driver for the integrated video, and I bet it has something to do with this bug:


Since the "freezing" is a kernel panic. Try:

grep i915_hangcheck_hung /var/log/*

And see what turns up. You might try turning off "use hardware acceleration when available" in chrome (under "Advanced Settings...System").

There's also a suggestion here (the above bug seems to be considered a duplicate of this one, but the one above has a better initial report involving chrome) to try this:

echo 0 | sudo dd of=/sys/module/i915/parameters/semaphores

If you do that su root it is a bit simpler:

echo 0 > /sys/module/i915/parameters/semaphores

Beware that the files in /sys are not real files on disk -- sysfs is a kernel interface. Reading a file is a request for live information from the kernel, and writing to a file is a live request to set a parameter. So this is not a permanent configuration that will persist across re-boots. You could include the echo command in a boot script, or add a kernel command line parameter in your grub.conf, as per the second bug report link:


Which will set that parameter at boot.

  • The grep command returns exactly the same error as the posted bug you pointed to: /var/log/kern.log.1:Sep 19 20:58:44 jeff-desktop kernel: [ 105.503162] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung. I'll try your two suggestions to see what happens. Thanks!
    – Fashandge
    Commented Sep 22, 2013 at 18:12
  • The problem comes back today... See the updated post.
    – Fashandge
    Commented Sep 23, 2013 at 20:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .