-1

I have wheezy installed from a pen drive. Updated things and thought I had got maven and eclipse. But maven projects would not compile. I uninstalled all the maven programs I could find in Add/remove software. That was 2 days back. Now can't remember what I removed and anyway fear something was missing. What -all- do I need to install to get maven working with java projects—run from command line and eclipse?

Should I reinstall eclipse/STS?

What I tried : downloaded libmaven-install-plugin-java_2.3-4_all.deb'

Tried to install :

 dpkg -i libmaven-install-plugin-java_2.3-4_all.deb 

Output:

Selecting previously unselected package libmaven-install-plugin-java. (Reading database ... 133826 files and directories currently installed.) Unpacking libmaven-install-plugin-java (from .../libmaven-install-plugin-java_2.3-4_all.deb) ... dpkg: dependency problems prevent configuration of libmaven-install-plugin-java: libmaven-install-plugin-java depends on libmaven2-core-java; however: Package libmaven2-core-java is not installed. libmaven-install-plugin-java depends on libplexus-digest-java; however: Package libplexus-digest-java is not installed.

dpkg: error processing libmaven-install-plugin-java (--install): dependency problems - leaving unconfigured Errors were encountered while processing: libmaven-install-plugin-java

2

Do not manually download packages and try to install them with dpkg. Instead, use apt-get or aptitude that will figure out the necessary dependencies and download and install the correct packages for you, for example:

aptitude install maven

I don't know anything about Maven, so I don't know if this is the correct package and if it's really the one your missing. You will have to figure that out by yourself:

http://packages.debian.org/search?keywords=maven

Now can't remember what I removed

Look into /var/log/dpkg.log, /var/log/aptitude.log and /var/log/apt/*. One of these log files probably contains information on what packages you removed.

  • well i re installed and it did not work (installed but still do not have a working maven) Same project works in mac but does not compile in my debian :( – tgkprog Sep 25 '13 at 15:09
  • will start a new thread for the real issue and maybe someone will be able to help. On other similar threads people seem to have solved by reinstall, i removed my ~/.m2 directory and reinstalled, but no cigar – tgkprog Sep 25 '13 at 15:11
  • marked this is as right as it did re install, but again not yet got my java to compile ! – tgkprog Sep 25 '13 at 15:12
1
dpkg -l libmaven-install-plugin-java |egrep ^ii

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.