6

I am running Mint 13 connected to a Dell U2711 monitor via displayport.

When the GDM logon screen is displayed, DPMS does not ever shut down the monitor.

If I logon and run

$ xset -q

I get

... 
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
...
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On

If I run

$ xset dpms force off

The monitor blanks for about two seconds, and then it comes back on again.

I have tried disabling my mouse as this post suggests with

$ xinput --set-prop [id] "Device Enabled" "0"

but no luck.

The symptoms are a little different than this post's, and I am not running gnome-power-manager.

Could someone please tell me what I am doing wrong?

Here is my video card and driver information:

$ lspci -v | grep VGA
05:00.0 VGA compatible controller: NVIDIA Corporation GF106GL 
[Quadro 2000] (rev a1) (prog-if 00 [VGA controller])
$ egrep -i " connected" /var/log/Xorg.0.log
[1743798.098] (II) NOUVEAU(0): Output DP-2 connected
$ egrep -i "drivers" /var/log/Xorg.0.log
[1743797.880] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[1743797.882] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[1743797.882] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
...

I also have:

$ grep DPMS /var/log/Xorg.0.log
[2246008.870] (II) Loading extension DPMS
[2246009.091] (II) NOUVEAU(0): DPMS capabilities: Off
[2246009.113] (==) NOUVEAU(0): DPMS enabled
3
  • What exact graphics card model do you have? What driver are you using (free or proprietary)? Sep 21, 2013 at 23:22
  • I've added card and driver information.
    – jsp
    Sep 24, 2013 at 2:59
  • Can you please provide your Xorg.conf and it's log file ?
    – SHW
    Sep 30, 2013 at 8:02

1 Answer 1

1
+50

The problem may be your driver. Try using the NVidia driver and see if it fixes the problem. According to this guy, who also had problems with a Dell U2 series monitor said the problem was with the Nouveau drivers: https://bbs.archlinux.org/viewtopic.php?id=130972

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .