6

I mounted a folder on a remote machine using sshfs, but didn't specify -o allow_other flag thus can't access the mounted directory.

When I try to mount over with -o allow_other option sshfs gives me this error:

mount: according to mtab, xxx is already mounted on yyy

To allow mounting over existing mount points I specified -o nonempty - but with no luck - got the same error as above.

When I try to unmount the mount point:

fusermount -u mountpoint

I get the error:

entry for yyy not found in /etc/mtab

So, what do I do to unmount the incorrectly mounted point?

5
  • What's mount output? Sep 21, 2013 at 3:34
  • @MohsenPahlevanzadeh user@remotemachine:path on yyy type fuse.sshfs (rw,nosuid,nodev,max_read=65536)
    – Mitten
    Sep 21, 2013 at 3:46
  • @Mitten - can you move that output into the Q? It's hard to follow what it's doing.
    – slm
    Sep 21, 2013 at 3:54
  • mount -a , however you got your answer. Sep 21, 2013 at 9:17
  • Entry for yyy not found in /etc/mtab can also mean that you misspelled the path of the mount point.
    – TNT
    Jun 24, 2017 at 17:46

1 Answer 1

3

If the filesystem is already mounted and you need to change the mount options, you must remount the filesystem. You can either umount then mount or you can use the remount option to mount. Here is an example:

mount -t sshfs -o remount,allow_other foo:/bar /some/path
5
  • 1
    Is it mounted if he can't fusermount -u mountpoint?
    – slm
    Sep 21, 2013 at 3:53
  • 1
    @slm His mount and fusermount commands do contradict each other.
    – jordanm
    Sep 21, 2013 at 4:06
  • 2
    sudo unmount yyy did the trick. when executing unmount yyy under non-root it was producing the error: unmount: yyy is not in the fstab (and you are not root) so I sudo-ed the command and viola - it worked!
    – Mitten
    Sep 21, 2013 at 5:19
  • @TomHale Change sshfs to the file system type that you are trying to remount eg ext4
    – jordanm
    Apr 3, 2017 at 4:16
  • I needed mount -t fuse.sshfs ....
    – Tom Hale
    Apr 3, 2017 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.