glibc-static.x86_64 0:2.12-1.107.el6_4.4                                 glibc-utils.x86_64 0:2.12-1.107.el6_4.4

Dependency Installed:
  fontconfig.x86_64 0:2.8.0-3.el6        freetype.x86_64 0:2.3.11-14.el6_3.1     gd.x86_64 0:2.0.35-11.el6        libX11.x86_64 0:1.5.0-4.el6
  libX11-common.noarch 0:1.5.0-4.el6     libXau.x86_64 0:1.0.6-4.el6             libXpm.x86_64 0:3.5.10-2.el6     libxcb.x86_64 0:1.8.1-1.el6

[root@host728 ~]# rpm -Uvh pptpd-1.3.4-2.fc19.x86_64.rpm
warning: pptpd-1.3.4-2.fc19.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 862acc42: NOKEY
error: Failed dependencies:
        libc.so.6(GLIBC_2.14)(64bit) is needed by pptpd-1.3.4-2.fc19.x86_64
        libc.so.6(GLIBC_2.15)(64bit) is needed by pptpd-1.3.4-2.fc19.x86_64

[root@host728 ~]# uname -a
Linux host728.me.net 2.6.32-042stab079.4 #1 SMP Thu Jul 18 18:57:29 MSK 2013 x86_64 x86_64 x86_64 GNU/Linux
[root@host728 ~]#

What am I missing here?

Do I need a different RPM that is RHEL based?

I am running CentOS 6.x

  • 1
    You need version 2.14 and have version 2.12 installed.
    – terdon
    Sep 20, 2013 at 14:27
  • The problem occurs when you try to install a fedora package on CentOS. How about that? Apr 22, 2014 at 11:23
  • Also, that's not really CentOS. It is part of the CentOS userland installed in an OpenVZ container. What you install will be severely limited, particularly if you want to load kernel modules.
    – jsbillings
    May 24, 2015 at 13:09

1 Answer 1

glibc-static.x86_64 0:2.12-1.107.el6_4.4

That's not the normal glibc, it probably doesn't have a .so in it at all.

Of course, your system wouldn't be running without a libc.so. Try whereis libc.so.6. And install the plain glibc.x86_64.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .