0

I keep getting this error:

./binary: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./binary)

I tried the instructions here:

https://superuser.com/questions/537683/how-to-fix-lib-x86-64-linux-gnu-libc-so-6-version-glibc-2-14-not-found

But when I run sudo apt-get -t experimental install libc6 it says the newest version is already installed, even though it clearly isn't because a) I just added experimental, and b) I still get that same error every frigging time I try to do anything. Is there any way I can get it to install?

EDIT: To confirm that the experimental version isn't installed:

libc6:
  Installed: 2.13-38
  Candidate: 2.13-38
2

There is no version of libc6 in debian experimental at the moment. The version that was in experimental has been migrated to sid and thence to testing, and has also been updated several times since then.

Like sid and testing, experimental is a moving target.

At this moment in time, debian has the following versions of the libc6 package:

stable aka wheezy: 2.13-38
testing aka jessie: 2.17-92+b1
unstable aka sid: 2.17-92+b1

Your choices at the moment are to stay with 2.13-38 and recompile your program against that version of libc6, or upgrade to 2.17-92+b1 from sid or testing. You might still have to recompile your program after upgrading to 2.17

  • Most of the programs getting this error are closed source, so testing would be the best option? – tkbx Sep 20 '13 at 2:53
  • yep. testing or sid. at this exact moment in time, they both have the same version of libc6. – cas Sep 20 '13 at 2:54
  • The particular program I was hoping for is now getting OpenGL related errors, but a multitude of other programs that were getting errors before are now working fine. Many thanks! – tkbx Sep 20 '13 at 3:01
  • let me guess - trying to run binaries compiled for ubuntu 12.04 or thereabouts? i had the same problem testing the linux steam client on my debian laptop several months ago. anyway, at least the libc compat is solved, now you've only got the opengl problem to deal with. – cas Sep 20 '13 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.