8

I installed several operating systems on my computer in a multiboot configuration (Ubuntu, Linux Mint, Windows, ...). When I turn on my PC, the boot menu appears with a timeout. Sometimes, I don't focus on it (I turn on my PC and then I go to the fridge to get a soft drink, for example) so that I miss the boot menu so I cannot chose my desired OS. Because of that, I must restart my computer and choose my desired OS again. Is there anyway to remove the timeout. I mean when the boot menu appear, so that there is no timeout, no OS will boot until I chose my desired OS.

I am using Ubuntu and Linux Mint.

16

I'm assuming you're using GRUB2 as your bootloader. You can disable the timeout by opening the file /etc/default/grub and changing the value of GRUB_TIMEOUT:

GRUB_TIMEOUT=-1

will disable the timeout feature.

See here for more information and settings.

  • 4
    +1. you also need to run update-grub (a wrapper around grub-mkconfig) to re-generate /boot/grub/grub.cfg after editing /etc/default/grub` – cas Sep 20 '13 at 3:16
  • Is there a way to make it select the default OS and run immediately without waiting? I was assuming that one could just set GRUB_TIMEOUT=0. But I don't want to see the menu at all. – CMCDragonkai May 26 '14 at 4:36
  • 2
    @CMCDragonkai - GRUB_TIMEOUT=0 should work, as stated here. I'd suggest making another question with a little more context if it doesn't. – raehik May 27 '14 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.