1

I am running Linux Slackware 14.0. I wanted to allow to do su only to the members of wheel group, so I modified the permissions of /bin/su and /usr/bin/sudo files to this:

bash-4.2# ls -la /bin/su
-rws--s--- 1 root wheel 59930 Sep 14  2012 ./su

bash-4.2# ls -la ./sudo
-rws--s--- 1 root wheel 107220 Jun 29 2012 ./sudo

Now when I am a member of wheel group and run su, it promts for password, I enter it. No errors are shown, but doesn't switch me to root. Probably, I set some permissions wrong?

  • Group is missing read access, by the way. – dawud Sep 19 '13 at 8:42
1

You could try

chown root.wheel /bin/su
chmod o-x /bin/su

so su will belong to wheel group and the others won't be able to run it. It seems to me that chown should solve your problem, setting properly all the permissions, since you just set up the execution rights previously.

0

No need to modify the permissions of su or sudo.

this kind of config is done in /etc/sudoers, you must edit it with visudo.

  • 3
    su does not read configuration from /etc/sudoers – Matt Sep 19 '13 at 8:40
  • 2
    It seems kinda pointless to change the behaviour of su though... it requires the password of the user you want to become so it's not really different from just logging in directly as this user. Screwing with the permissions could very well break programs that rely on su or sudo to work properly. – Martin von Wittich Sep 19 '13 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.