2

I'm on Linux Mint 15 (MATE edition) (based on Ubuntu 13.04), and I'm using a Logitech G700 mouse. Since the mouse has a pretty high sensitivity, and I don't like mouse pointer acceleration, I use the following bash script to get a well behaved mouse pointer:

#!/bin/bash

xinput set-prop 9 'Device Accel Profile' -1
xinput set-prop 9 'Device Accel Constant Deceleration' 2.5

# I'm not sure this does anything:
xinput set-prop 9 'Device Accel Velocity Scaling' 1.0

This removes all mouse acceleration, and turns down the pointer speed to a level I think is good. The problem is that the mouse pointer movement is kind of jittery and erratic. I can't really explain it, but it makes the pointer hard to control. I use the same mouse on Windows 7, where I turn of mouse acceleration using the SetPoint software, and there the pointer movement is perfect and very easy to control.

I tried lowering the sensitivity on the mouse itself and lowering the Constant Deceleration, but the problem persists. Does anyone know if there's any other way to fix this?

I found an option called "Softening" in the Xorg documentation, but I don't really know how to enable it. I'm guessing I have to edit the Xorg config file, but I'm unsure of how to do this.

0

It seems like the problem in this case was a hardware problem, not a software one. After getting a replacement mouse I no longer have any problems.

The strange thing is that I didn't have any real issues in Windows, but I guess that's some kind of smoothing process being applied by the OS or the drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.