1

On my Arch machine, I wanted to play the DVD Skyfall. It opened with VLC, and everything worked, except that everything was a bit greenish. Why is that happening? Dragon player isn't better either. The odd thing is that, when I tested other DVDs, it worked. Skyfall also had no problems on my PowerBook, with Mac OS 10.5. This is a bit of an odd question, but I don't understand why that should happen.

5

Try mplayer (or a frontend like smplayer).

The issue is related to OpenGL hardware GPU accleration reference

It would be helpful to know which GPU you have. Arch recently enabled SNA acceleration by default for Intel GPUs. If it's an older GPU (intel/nvidia/ati) it likely doesn't have support, so disable hw accel.

  • I've got an i3 CPU with a h61 chipset. Smplayer didn't help. – MadTux Sep 19 '13 at 18:29
  • Based on that limited info, you either have Intel HD2000, HD3000, or maybe even using an Nvidia or AMD GPU. Regardless see if UXA acceleration fixes the issue. And make sure you have the latest xf86-video-intel driver package installed. – justbrowsing Sep 19 '13 at 20:00
1

I have had similar problems and it turned out it depended on which output module you have selected. For example, in vlc:

enter image description here

I would guess the same applies to the other programs. Try Xvideo and X11 video first but depending on your setup,it may be one of the others as well. Also, vlc sometimes needs to be restarted for the settings to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.