18

In terminal emulators like GNOME terminal, I can hold the control key and use my mouse to select a block of text. Doing the same in Konsole has no effect -- the mouse simply selects one character after another, to the end of each line, wrapping around, as if I were using GNOME terminal and selecting text without holding the control key.

How can I block select text in Konsole?

1
  • In the unlikely event that someone arrives here wondering why block selects don't work for them in konsole or GNOME terminal in e.g. VirtualBox running under macos: it should work if you disable mouse integration. Macos interprets Ctrl-click as a right-click.
    – sneep
    Commented Jul 14, 2023 at 7:05

2 Answers 2

37

It's Ctrl+Alt.

Found it mentioned in KDE bug tracker, Bug 122831 Block selection mode shortcut is not documented:

pressing the Ctrl and Alt keys while selecting text will let Konsole select columns

Bug resolution is that key strokes to handle block selection are in the help docs since KDE 4.8.

2
  • 3
    Doesn't work with tmux though
    – baldrs
    Commented Sep 12, 2017 at 10:44
  • yup , it works in konsole ! thanks !
    – neofutur
    Commented Sep 16, 2022 at 7:52
1

I can confirm that Ctrl+Alt works (and yes, even in tmux).

(but I'm pretty sure you figured it out by yourself 6 years ago)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .