1

I'm using apticron to notify myself about available updates. However, I've got an installation on a VPN that seems to notify about packages I DON'T have installed. For example, it keeps (daily) suggesting that I upgrade sysvinit - I have upstart installed, not sysvinit. I used to have it for a number of other packages (basic libraries that weren't installed in my original Debian-wheezy image), so I've shut up those warnings just by installing the libraries. However, I don't really want to ditch upstart for sysvinit just to make apticron play more nicely.

Any ideas how to make it stop?

1

Okay, found my own answer - and slightly embarrassed I didn't spot this in the config file before I posted:

# Set NOTIFY_NEW="0" if you don't want to be notified about packages which
# are not installed in your system. Yes, it's possible! There are some issues
# related to systems which have mixed stable/unstable sources. In these cases
# apt-get will consider for example that packages with "Priority:
# required"/"Essential: yes" in unstable but not in stable should be installed,
# so they will be listed in dist-upgrade output. Please take a look at
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=531002#44

sysvinit, of course, is considered required/essential (as were the others I had installed to silence the notifications). So, setting

NOTIFY_NEW="0"

in /etc/apticron/apticron.conf solves the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.