1

While installing proftpd, it dropped with following error:

[....] Starting ftp server: proftpdhexadecacordis proftpd[26849]: mod_tls_memcache/0.1: notice: unable to register 'memcache' SSL session cache: Memcache support not enabled
. ok 
Setting up proftpd-mod-vroot (0.9.2-2+b2) ...
Errors were encountered while processing:
 linux-image-3.2.0-4-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

I first did not notice linux-image-3.2.0-4-amd64 error, so I tried to set up libmemcache, and it dropped with same error.

So, I ran an upgrade, and everything updated, except following. So I ran it again, to display clear view of error:

# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  xserver-xorg-input-all
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up linux-image-3.2.0-4-amd64 (3.2.46-1+deb7u1) ...
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
run-parts: executing /etc/kernel/postinst.d/zz-runlilo 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
Warning: LBA32 addressing assumed
Fatal: Incompatible Raid version information on /dev/md0   (RV=0.90 GAI=1.2)
run-parts: /etc/kernel/postinst.d/zz-runlilo exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-4-amd64.postinst line 696.
dpkg: error processing linux-image-3.2.0-4-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 linux-image-3.2.0-4-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

I can't find any solution connected with "Incompatible Raid version information".

Please, explain me how to solve this problem.

  • Actually, there are quite a few Google hits when searching "Fatal: Incompatible Raid version information on /dev/md0" . It seems you're using lilo as a bootloader (any special reason?) and your problem is soft RAID + lilo - specific. If you want to continue using lilo, please paste the output of # mdadm -E /dev/md0 and we'll take it from there. – schaiba Sep 16 '13 at 13:32
1

It appears that you are using LILO to boot, and it does not understand the new mdadm metadata format. You should switch to grub2 instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.