I am confused as when X is started, how it is visible on screen. Does a new Window appear or not? I am very confused! I booted, opened a shell terminal.

Below I write regarding my local machine:



The terminal emulation window (xterm) appeared. Now, I conclude that X is already running and so is X server. Then I entered in terminal


It resulted in a different screen. Looked like normal screen when the system is booted. But that screen has no menus. If 2 windows are opened one above the other, I can't bring the bottom one on top simply by clicking it.

One thing I w'd like to add. Once I run 'startx' and a new screen/desktop appears, it's not a direct easy way to come out from there. Right now I experimented. I wasn't able to come out from that desktop. Button function 'alt-tab' doesn't work there. To escape from there back to my original desktop, i pressed ctrl+ALT+F1 and entered shell prompt. there I pressed ctrl+ALT+F7 to return back to my original desktop.

Now one doubt: Earlier before running command startx,was X running, if so when I again ran X by the above command , why it opened a new screen? That means, X is running again with a different look (i.e. different desktop)

Below I write regarding my remote machine.

One thing I w'd like to tell w.r.t. my remote server. One thing I w'd like to tell w.r.t. my remote server. When I connect remote server of mine (VPS) I see the desktop or the screen on the remote box which is same screen/wkndow as what I saw on my local machine when I ran on my local machine startx. From this I feel that something like startx is running on my remote server as a result of which I am not able to see the normal desktop as seen on local (having menus on left, etc). There was no menu visible as is visible on my local machine. You can see the screen shot for clarity of how my remote destop looks like when I connect to remote machine. The menu visible on the screen shot is of my local machine. The top most window is my remote machine. There also I can't change size of any window. It works the same way as when here locally I ran startx. Now please tell me what can I do so that I get menu on my remote machine. If there everytime something (as told above) is running, how to stop and get back to my normal desktop that we all (ubuntu 13.04 users)see after the system is booted. What to do so that the remote also looks the same as my local box. Both local and remote has ubuntu13.04

It's too unclear as how X looks.

Below is screen shot of my remote machine as visible when I connect to it. (the top most window/screen heading: NX-ravbholua@ravi:1002-bholua) enter image description here

  • Please edit your question to explain what exactly you're doing. You said booted but in your comment below you say you are trying to connect through VNC. We need to know exactly what's going on, how many computers are involved, what you're doing on each of them etc. – terdon Sep 15 '13 at 15:34
  • Oh! sorry if it wasn't clear. See I have written about 2 computers. The paragraph inside the quotes that starts with: "One thing I w'd like to tell w.r.t. my remote server", is only about my remote server. The other text is regarding my local machine. When I say boot, it's my local and when I say connect ,I am connecting to remote server. – Ravi Sep 16 '13 at 7:17
  • @Ravi please do some reading on what X is prior to posting a question. en.wikipedia.org/wiki/X_Window_System – strugee Sep 17 '13 at 5:13
  • @strugee Thanks for the link. I w'd go through that. Just I thought to mention one point that what I had posted is after a lot of reading and research. I had read the chapter on X from the book named UNIX:CONCEPTS and APPLICATIONS by Sumitabha Das. Now I had the doubt what I posted. I also googled and gave a look at few internet sites to get the answer of my question. But unfortunately I coldn't get a solution. From my post, any reader should understand that I had experimented/practised X. – Ravi Sep 18 '13 at 13:20
  • Here is one question of the book that really makes me think again the query I asked in this post: Qn) What happens if all the commands in .xinitrc are placed in the background? Answer given is: Ans) The commands will all be executed and then X will be terminated. Now one question arises that X is terminated but xterm (one of the command in .xinitrc) is running. How come? – Ravi Sep 18 '13 at 13:21

The X Windows System's local X server doesn't "look" like anything other than a grey background and a mouse pointer, if it is started without a window manager or any other X client. If you were able to start another terminal window, then you are running some sort of X client, possibly just an xterm.

When you started another X session with startx, it might have started it inside some sort of Xnest session (I'm not familiar with ubuntu, so I am not sure), which is just an X client that can start a new, nested X session, displaying to the existing X server rather than running directly on the video hardware. It's not clear from your description.

As for your remote session, it isn't clear how you're starting your X session, but it sounds like VNC. In that case, you need to edit your ~/.vnc/xsession file to have it start the appropriate X clients, such as an X window manager such as openbox or even a Desktop Manager such as Gnome or KDE.

  • I have added an attachment which seems to have been missed earlier. I am connecting to my remote server via NX (www.nomachine.com). I am not starting X there. When I connect to it, I see a screen without menu. That screenshot is attached in my post. I want it to be visible as my local ubuntu looks like having menu on left corner. More details on how the remote server works is mentioned in my post. – Ravi Sep 15 '13 at 15:19
  • It looks like your NX session has started some part of your graphical login environment, but has stalled/stopped, because the default X background doesn't have that colorful background. It apears that the default Unity login session isn't compatible with NX: nomachine.com/fr/view.php?id=FR06I02466 and that you should change it to something else: nomachine.com/ar/view.php?ar_id=AR0500591 (keep in mind, I have little experience with Ubuntu, so any more experienced users can jump in) – jsbillings Sep 15 '13 at 15:34
  • @terdon, I have edited my 1st post for more clarity – Ravi Sep 17 '13 at 4:06
  • @Ravi if you see anything but a console (what you get when you press Ctrl-Alt-F1), it has started X. – strugee Sep 17 '13 at 5:12
  • @jsbillings Great!! You really succeeded in catching the problem. I communicated with www.nomachine.com and yes it is most probably the issue that nomachine doesn't support Unity desktop. (nomachine.com/ar/view.php?ar_id=AR07K00676) I w'd replace it with a compatible one and update you. But yes, you are really praiseworthy that you went to nomachine.com and finally got the issue. I thank you jsbillings for your effort and assistance. – Ravi Sep 19 '13 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.