1

I recently bought a new laptop which came preinstalled with Windows 8 (no! please don't run away yet!). I'd like to try and put Linux on it in a dual boot (probably Ubuntu, with its UEFI support), but before that I'd like to make a system image with Clonezilla in case I mess up, or in the more likely case that UEFI causes something else to mess up.

Te problem is that when I put the Clonezilla CD in the drive and reboot, I get its GRUB menu, but after selecting an option the screen just goes black and stays that way. It still responds to a CTRL+ALT+DELETE at that point. I tried both stable-amd64 and alt-stable-amd64 to no avail. I have also tried 800x600, 1024x768 and safe graphics mode.

I have secure boot disabled. The system is an MSI GP60 2OD. Any help would be appreciated.

Update

It would appear that this problem not only occurs when trying to boot Clonezilla, but with any Linux-based system. It simply won't boot.


The only thing I notice is the orange light that indicates NVidia Optimus is using the NVidia GPU (or in Windows, that's what it indicates, anyway). Also, the fans get louder and the air coming out of the side gets hotter. The system is not completely frozen, seeing as pressing the power button, CTRL+ALT+DELETE or the fan boost button still does what I'd expect it to do.


I can boot a Linux live CD when I put UEFI into Legacy mode, but then I can't boot Windows, and I need them both.


Update

I managed to install elementary OS (based on Ubuntu 12.04) in Legacy mode, installing the boot loader on the root partition (/dev/sda9) to avoid it completely messing up the Windows boot loader. At the end the Windows boot loader still got messed up, but I managed to restore it. Now, when I put UEFI in Legacy mode, it doesn't find an operating system. And when I put it in UEFI (with CSM) it boots Windows 8.1. I tried adding an entry for elementary OS in the Windows boot loader with EasyBCD, but to no avail (the option appears in the boot loader, but it just shows me an error about some file missing or being corrupted). Can anyone tell me if there's any way for me to add elementary OS to the Windows boot loader? Other options are welcome, too. Although this would be the preferable scenario because I would get to keep Fast Boot.


Specifications

  • MSI GP60-2OD
  • Intel Core i7-4700MQ
  • NVidia GeForce GT 740M (Optimus)
  • Take a look at askubuntu.com/a/231104 – PMint Oct 21 '13 at 15:02
  • @PMint Unrelated to my question. – RobinJ Oct 21 '13 at 16:41
  • From my own research it looks like the best laptops with UEFI that work with Ubuntu without issue are the Dell XPS 13 and Asus Zenbook UX31A – user46865 Oct 26 '13 at 6:26
2

I had a similar situation (laptop with Windows 8 preinstalled which I did not want to bury yet, and Linux installed but not wanting to boot), and I solved it using the following steps:

  1. I set the BIOS to Legacy mode, with secure boot option disabled, and booted into the live USB which I had been able to install Linux with: Backbox 3.09, which is based in Ubuntu 12.04.
  2. Once inside the Live session, I installed Boot-Repair tool (copy/paste a couple of commands), and this fixed Grub. At this point, I was able to boot into linux even if I disabled the Legacy Mode (indeed, the legacy mode gave me low console resolutions, so I disabled it and I had full HD consoles).
  3. Once inside Linux, I repaired Windows 8 Boot again using rEFInd (downloaded the .deb package and installed using dpkg). After that, I could enable the Fast Boot option again and at boot I have a nice graphical menu where I can choose to boot Windows 8, the Windows 8 Recovery tool, the old good Grub menu, or directly one of the Linux Kernels.

To be honest, I think that the boot-repair step was not necessary, but I didn't discover rEFInd until I had already broken Windows 8 boot. So, maybe you might want to try to install rEFInd directly from the LIVE boot.

Bear in mind that, in the worst scenario of rEFInd not working, you will still be able to boot into your live USB again, remove it (it's just a command), and then go for the boot-repair option.

  • All I achieved with this is that I broke GRUB, unfortunately :( Booting in UEFI mode still simply brings up Windows, while booting in Legacy mode will present me with a grub rescue> prompt. – RobinJ Oct 29 '13 at 21:27
  • This is what I had before using boot-repair tool. Did you use it, or did you jump directly into rEFInd? If you used it, bear in mind that there are many options to configure (I'm afraid I don't remember which ones I used). Otherwise, give it a try. – Carles Sala Oct 29 '13 at 22:11
  • I didn't even get to running rEFInd. After running Boot Repair I rebooted and was presented with a GRUB rescue prompt. I suppose I should be able to fix that, too, with Boot Repair :p – RobinJ Oct 31 '13 at 9:07
1

Try including GRUB_GFXMODE=vga=vesa after nomodeset. If that doesn't work then try replacing nomodeset with nvidia.modeset=0 and include GRUB_GFXMODE=vga=vesa.

0

Try hitting E at the grub menu, then go to the line with the kernel options and remove quiet and add nomodeset. Exit and reboot.

The usually does the trick. If it doesn't you can try any of noapic,nolapic,acpi=off,noacpi but I doubt any of those will be the issue these days.

  • Already tried that. Plus nomodeset is already there, so I don't need to add it. – RobinJ Sep 13 '13 at 8:24
  • @RobinJ try deactivating switchable graphics in the BIOS and booting with the integrated graphics adapter. – terdon Sep 13 '13 at 13:55
  • No such option, as far as I can tell. – RobinJ Sep 13 '13 at 17:26
  • @RobinJ strange, there usually is something about allowing the OS to switch the graphics. I hate to say this but it might not be worth the effort, you might be better off using a windows cloner like norton ghost instead. – terdon Sep 13 '13 at 17:46
0

You should use : GRUB_TERMINAL=console and GRUB_TERMINAL_OUTPUT=console.

0

As far as I can tell, it's simply not possible to do it. Some distro's would get as far as to print "Secure Boot disabled" (or something similar) to the console before hanging, but eventually all of them would hang after GRUB.

I ended up setting UEFI to Legacy mode, as that appears to be the only option anyway.

0

I had a similar issue where i could not get past the orange Clonezilla splash screen, on a Clevo P651RP6-G with Nvidia Optimus.

There is an option in the BIOS settings (American Megatrends Bios) in Advanced Menu > Advanced Chipset Control to set the graphics switch from MSHYBRID (Nvidia Optimus) to DISCRETE (only use discrete GPU). That solved the issue for me. Maybe you have a similar option in your BIOS?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.