1

I want to enable quotas.

My fstab currently has:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=97439827-cdb6-4406-8403-76ab1de7a3b0 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=194bd177-cba0-415d-b45d-bd87b7bf446e none            swap    sw              0       0
durrantm:~/Dropbox/96_2013/work/code
$ 

If I want to add usrquota,grpquota to enable user and group quotas, do I put them after errors=remount-rov, e.g. errors=remount-rov,usrquota,grpquota

1
  • before or after makes no difference, as long as the mount options are separated by commas. also, remount-rov is a typo, should be remount-ro - be very, very careful about typing and other mistakes when editing /etc/fstab - you can easily make your system unbootable. such problems are easily fixable, but require a good understanding of the linux boot process and at least intermediate level unix command-line skill, as well as a methodical non- panic-prone approach.
    – cas
    Sep 14, 2013 at 1:31

1 Answer 1

3

As per man page of mount

We can define only three option in errors i.e continue|remount-ro|panic

errors={continue|remount-ro|panic}

Define the behaviour when an error is encountered. (Either ignore errors and just mark the filesystem erroneous and continue, or remount the filesystem read-only, or panic and halt the system.) The default is set in the filesystem superblock, and can be changed using tune2fs(8).

So you just need to add like this :

/dev/sda1  /mount_point               ext4    usrquota,grpquota,errors=remount-ro 0       1

then just remount partition :

mount -o remount /mount_point

then check in mount command

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .