2

I'm using cygwin and cygwin X server, I'm having a problem with xterm. Every time I start it I have to set its parameters via the menu.

Is there a way to make them set to true by default?

I found a file named /etc/X11/app-defaults/XTerm which I believe should be used to put default settings to XTerm, but I can't find correct parameters names and values.

  • What command line options are you wanting to make default? – Drav Sloan Sep 10 '13 at 21:02
1

The file /etc/X11/app-defaults/XTerm defines X resources used by Xterm. X resources are configuration values used by old-fashioned X applications (applications that came before modern environments such as Gnome and KDE which have their own, less powerful configuration system).

Don't modify the system file. Instead, write your own settings in ~/.Xresources. Most setups read this file automatically, but on Cygwin, you may need to run it manually.

Resource settings have the form SETTING: VALUE where SETTING consists of dot-separated names. The first name is the name of the application whose setting you're specifying (here, XTerm), then zero or more nested components (“widget”) and finally the resource name. The manual page documents the resource names.

XTerm.VT100.utf8: 1
XTerm.VT100.renderFont: true

Resource names are case-sensitive. StudlyCapsified names designate classes while lowercase names designate instances. You don't really need to understand what this means; if it ever comes up, be aware that settings for an instance take precedence over settings for a class.

  • to add to your answer, I also added XTerm*faceName: Monospaced and trueType fonts became true. – dhblah Sep 11 '13 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.