3

I'm trying to install the various i386 libraries required for skype on linux (debian 7.0 wheezy 64-bit), but I've run into a problem where apparently the two versions of libsqlite-3-0 are each blocking the other. Here's the output from aptitude:

libsqlite3-0 : Breaks: libsqlite3-0:i386 (!= 3.7.16.2-1~bpo60+1) but 3.7.13-1+deb7u1 is to be installed.
libsqlite3-0:i386 : Breaks: libsqlite3-0 (!= 3.7.13-1+deb7u1) but 3.7.16.2-1~bpo60+1 is installed.

I've done a bit of tracking, and here is what I know about those packages:

  • libsqlite3-0:i86 is not yet installed.
  • libsqlite3-0:amd64 (the normal one) is installed, but instead of the wheezy default of 3.7.13-1, I have a different version from squeeze-backports (from before I upgraded to wheezy): 3.7.16.2-1.
  • A google search for libsqlite3-0 3.7.16.2-1 finds several pages about iceweasel. I've tried removing iceweasel, but that's not an option; gnome-core depends on it apparently.

Any ideas for how to resolve this, or investigate further?


FYI: derobert's advice got this sorted. The command I needed was this one, to downgrade the libsqlite3-0 (amd64) package:

aptitude installpackage=version

e.g. in this case aptitude installlibsqlite3-0=3.7.13-1+deb7u1

in full:

root@hephaestus:/etc/apt# aptitude install libsqlite3-0=3.7.13-1+deb7u1
The following packages will be DOWNGRADED:
  libsqlite3-0 
0 packages upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 455 kB of archives. After unpacking 48.1 kB will be freed.
Get: 1 http://ftp.uk.debian.org/debian/ wheezy/main libsqlite3-0 amd64 3.7.13-1+deb7u1 [455 kB]
Fetched 455 kB in 1s (452 kB/s)       
dpkg: warning: downgrading libsqlite3-0:amd64 from 3.7.16.2-1~bpo60+1 to 3.7.13-1+deb7u1
(Reading database ... 179321 files and directories currently installed.)
Preparing to replace libsqlite3-0:amd64 3.7.16.2-1~bpo60+1 (using .../libsqlite3-0_3.7.13-1+deb7u1_amd64.deb) ...
Unpacking replacement libsqlite3-0:amd64 ...
Setting up libsqlite3-0:amd64 (3.7.13-1+deb7u1) ...
3

The ~bpo in the version number means it comes from Debian backports. If you check packages.debian.org, you'll see that the version you have installed is from squeeze-backports.

Also, the :i386 means that it's a 32-bit version.

So it looks like you had Squeeze installed before and also Squeeze backports. And also 32-bit squeeze backports. Or at least, you had that backport installed.

The fix is to upgrade your squeeze backports to Wheezy versions. I suspect that didn't happen automatically because you don't have multi-arch enabled. See https://wiki.debian.org/Multiarch/HOWTO and https://wiki.debian.org/Multiarch

  • Thank you - yes, I did have squeeze installed before, and squeeze backports. I'll look into upgrading those squeeze backport packages. – Vince Bowdren Sep 10 '13 at 7:23
  • Worked completely, cheers. – Vince Bowdren Sep 10 '13 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.