I'm trying to make a bootable usb in ubuntu for fedora, but my settings are not working.

I formatted the USB with FAT & Ext4, MBR, and Legacy BIOS bootable.

My BIOS allows the USB 3.0 controller to be turned off and for UEFI to be in CSM compatibility mode. I've tried many more combinations than above, but nothing works.

Once I format, I copy the ISO with sudo dd if=~/Downloads/Fedora-Live-Desktop-x86_64-19-1.iso of=/dev/sdb1 bs=8M.

How can this be resolved?


I formatted FAT32 and used unetbootin. Still won't boot.

UEFI translation

Apparently, UEFI is MS protectionist crap. If there's a use for it, I haven't seen a single page explaining it. This should be disabled. Nevertheless, my system still says that no operating system can be found when I choose to boot from the USB.

Note: the USB data doesn't even show when UEFI is enabled. Thought it was due to the way I was formatting.


I created a 13.04 USB, and it worked no matter what except for fast boot. When UEFI is set to CSM, and SATA to IDE, ubuntu's boot looks like an old school CRT for boot and shutdown, but the desktop loads just as in UEFI.

Ubuntu's "Disks" program reports 1 parition on the entire 2gb, usb 2.0 drive:

  • Partition Type: W95 FAT32 (LBA) Bootable)
  • Contents: FAT (32-bit version)

gdisk reports that the usb has not been converted to GPT.

In bios, the USB drive shows up no matter what configuration is used with ubuntu. With all other methods, it's a blank entry.

dd formatting & async

Using these commands, bios still cannot even see the USB drive, still a blank entry.

sudo umount /dev/sdb*
sudo dd if=/dev/zero of=/dev/sdb
sudo sync
sudo dd if=Fedora-15-x86_64-netinst.iso of=/dev/sdb
sudo sync
  • 2
    UEFI does have a point. It's replacing the long-obsolete-but-kept-because-MS-couldn't-bother-updating-their-OS BIOS interfaces on PCs. See e.g. the Wikipedia article. The problem with UEFI and MS is how MS hijacked secure boot to make sure that only they would have the key in practice. Secure boot itself is a good thing, as long as the owner of the computer owns the key (if you don't own your PC's boot key then you don't really own it). Sep 7, 2013 at 21:50
  • @Gilles since ubuntu worked, do they have the keys, or have they found some kind of workaround?
    – user31705
    Sep 7, 2013 at 22:38
  • 1
    @Gracchus - yes they have keys: blog.canonical.com/2012/06/22/… as does Red hat: redhat.com/about/news/archive/2012/6/uefi-secure-boot. They basically had to cave, the whole thing is ridiculous that Linux vendors have to get a key from M$ to run on UEFI enabled hardware.
    – slm
    Sep 7, 2013 at 23:48
  • @slm ah, ty! i take it omission means fedora doesn't?
    – user31705
    Sep 8, 2013 at 0:06
  • 1
    @Gracchus - no I mean they were included when I said RH. Should've been more specific 8-) fedoraproject.org/wiki/Features/SecureBoot
    – slm
    Sep 8, 2013 at 0:07

1 Answer 1


You don't have to format the USB Key just run :

sudo dd if=~/Downloads/Fedora-Live-Desktop-x86_64-19-1.iso of=/dev/sdb bs=8M

Be careful refer to the disk (/dev/sdb) and not to the partition. You run the right command the second time but you were using a netinstall iso and I am not sure it does handle secure-boot.

source : fedoraproject.org/wiki Regards, Loick

You must log in to answer this question.