3

I am using RHEL6

Hi i have created the yum repository, i downloaded the snort rpm package from their website when i tried to install the rpm its thorws error e.g.

snort-2.9.5.3-1.f18.i386.rpm

1:snort-2.9.5.3-1.i386 requires libsfbpf.so.0
1:snort-2.9.5.3-1.i386 requires libdnet.so.1
1:snort-2.9.5.3-1.i386 requires libpcre.so.1

1) I tried finding these files on the internet and couldn't find any

2) How do i install the snort using yum, i tried yum install \Desktop\snort-2.9.5* it threw error that i have failed dependecies

errors:

Resolving Dependencies
--> Running transaction check
---> Package snort.i386 1:2.9.5.3-1 set to be updated
--> Processing Dependency: libdnet.so.1 for package: 1:snort-2.9.5.3-1.i386
--> Processing Dependency: libpcre.so.1 for package: 1:snort-2.9.5.3-1.i386
--> Processing Dependency: libsfbpf.so.0 for package: 1:snort-2.9.5.3-1.i386
--> Finished Dependency Resolution
Error: Package: 1:snort-2.9.5.3-1.i386 (/snort-2.9.5.3-1.f18.i386)
           Requires: libsfbpf.so.0
Error: Package: 1:snort-2.9.5.3-1.i386 (/snort-2.9.5.3-1.f18.i386)
           Requires: libdnet.so.1
Error: Package: 1:snort-2.9.5.3-1.i386 (/snort-2.9.5.3-1.f18.i386)
           Requires: libpcre.so.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

How do i get snort to be installed, i even tried to install fwbuilder but failed

1

1 Answer 1

2

If you need to find out what repo package(s) contain a specific file, you can try (e.g.):

yum provides "*/libdnet.so.1"

This uses shell globbing, so "*/" covers the fact that yum will be looking through absolute pathnames. That is necessary. Note it searches your repositories, not just installed packages. For the example above using F17, I get:

libdnet-1.12-8.fc17.i686 : Simple portable interface to lowlevel networking routines
Repo        : fedora
Matched from:
Filename    : /usr/lib/libdnet.so.1



libdnet-1.12-8.fc17.x86_64 : Simple portable interface to lowlevel networking routines
Repo        : fedora
Matched from:
Filename    : /usr/lib64/libdnet.so.1

This one is fairly straightforward, but since this is a filename search, you may often get lots of hits and have to make a considered guess about what it is you are really looking for.

yum provides matches against a number of .rpm field headers, so you do not actually have to search for a specific file (but shell glob syntax always applies; the Provides: field often has stuff in it). E.g., just plain yum provides libdnet works here -- as of course does the more common and straightforward:

yum search libdnet

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .