7

PulseAudio does not appear to recognize the Focusrite Scarlett 6i6 USB audio interface. The 2i2, however, is properly recognized and it works as expected. I can't seem to get the 6i6 to work on the same system where the 2i2 worked. Both are said to be class compliant USB devices. I also tried the 6i6 on another computer with a fresh system installation (Kubuntu 12.04) and the result is the same -- PulseAudio doesn't see the 6i6.

Here's the only official info I found:

Linux and Focusrite / Novation products | Focusrite Development http://focusritedevelopmentteam.wordpress.com/2012/04/23/linux-and-focusrite-novation-products/

Should work: Scarlett 2i2, 2i4, 8i6, 18i6, 6i6, 18i8, 18i20, Saffire 6 USB MkII (USB audio class 2.0 compatible), Forte and iTrack Solo.

My experience is that the 6i6 does not work (while the 2i2 does). I'm hoping someone here has figured it out or can tell me the steps I need to figure it out.

$ lsusb
[snip other h/w]
Bus 001 Device 006: ID 1235:8012 Novation EMS 

$ cat /proc/asound/cards
[snip other h/w]
 1 [USB            ]: USB-Audio - Scarlett 6i6 USB
                      Focusrite Scarlett 6i6 USB at usb-0000:00:1a.0-1.2, high speed

$ pacmd list-cards
Welcome to PulseAudio! Use "help" for usage information.
>>> 1 card(s) available.
[the 6i6 is not shown, only the built-in sound card is shown]

I'm running Kubuntu 12.04 LTS (KDE) and System Settings -> Multimedia -> Phonon does not show the 6i6 at all.

Previously the 2i2 was recognized like this:

#lsusb
[snip other h/w]
Bus 003 Device 002: ID 1235:8006 Novation EMS 

$ cat /proc/asound/cards
1 [USB            ]: USB-Audio - Scarlett 2i2 USB
                      Focusrite Scarlett 2i2 USB at usb-0000:04:00.0-1, high speed

$ pacmd list-cards  
    Welcome to PulseAudio! Use "help" for usage information.  
    >>> 3 card(s) available.  
    [snip other cards]
    index: 2
    name: <alsa_card.usb-Focusrite_Scarlett_2i2_USB-00-USB>

Thanks

  • Did you try restarting PA after insertion? – Ignacio Vazquez-Abrams Sep 1 '13 at 23:31
  • @IgnacioVazquez-Abrams - I restarted the computer twice with the device plugged in. To restart PA, would you use pactl exit or some other method? Anyway, restarting the computer after insertion should have worked if the solution was that simple, right? – MountainX Sep 2 '13 at 0:20
  • On my system I'd just kill it and let the session manager bring it back up, but I'm not sure that would work on Kubuntu. – Ignacio Vazquez-Abrams Sep 2 '13 at 0:22
  • Isn't there anything relevant in the /var/log/dmesg? – Braiam Sep 2 '13 at 22:14
3

I found that after upgrading my kernel to 3.16.2 the soundinterface worked in linux mint 17. Details here: http://www.digitalstroopwafel.com/?p=141

3

This answer is outdated. See my other answer for newer information.

I solved this by installing KX Studio. The instructions can be found here: http://kxstudio.sourceforge.net/Documentation

These are the steps I used. (They are directly from the KX Studio documentation.) In my case it was required to install the low latency kernel. I tried the generic kernel first and that did not do the trick. Once I installed KX Studio and the kxstudio-kernel-lowlatency, my audio interface "just worked."

Step 1 - Enable the repositories

Open up the 'Software Sources' (usually in the System menu), and on the 3rd party separator, add this code: ppa:kxstudio-team/kxstudio Alternatively, you can run this command, which has the same effect: sudo add-apt-repository ppa:kxstudio-team/kxstudio

Next, reload the sources (method depends on the current application), and install the package 'kxstudio-repos'. Then reload the sources again. You can do the same thing in the command-line with: sudo apt-get update sudo apt-get install kxstudio-repos sudo apt-get update

NOTE: If you're running 12.04, it's recommended to also install 'kxstudio-repos-kde49' which will update KDE4 to the stable 4.9.5 version.

Step 2 - Update the system

Once you've got the repositories set-up, it's time to upgrade the system (ie, update the software, not upgrade to a newer Ubuntu release!).

Simply use whatever tool your Desktop Environment provides (Ubuntu Software Center, Synaptic, Update Manager, KPackageKit, Muon, etc). If you want to use the command-line, or if you just got too many dependency conflicts (can happen if you enabled many PPAs before upgrading to KXStudio), the command is: sudo apt-get dist-upgrade Even though it says 'dist-upgrade', it will not update the Ubuntu version. In this case, 'dist' means something like "resolve conflicts, even if some stuff gets removed".

This step will take some time. Some minor questions may appear while the upgrade takes place.

Step 3 - Install the KXStudio Desktop

After the upgrade, it's time to install the main KXStudio packages. Just like you did to install the 'kxstudio-repos' package, now install:

For KDE4 -> 'kxstudio-desktop-kde4' For XFCE -> 'kxstudio-desktop-xfce' For other systems install 'kxstudio-desktop-base' and the ubuntu related package, like 'lubuntu-desktop' for LXDE

Step 4 - Install the Multimedia Software

This step if almost optional. Here we install the basic software for Audio, Graphics and Video. Just like before, it's time to install some new meta-packages. They are available as listed here (following a tree view of dependencies):

kxstudio-meta-all
    kxstudio-meta-audio
        kxstudio-meta-audio-plugins
            kxstudio-meta-audio-plugins-dssi
            kxstudio-meta-audio-plugins-ladspa
            kxstudio-meta-audio-plugins-lv2
            kxstudio-meta-audio-plugins-vamp
            kxstudio-meta-audio-plugins-vst
    kxstudio-meta-graphics
    kxstudio-meta-video
kxstudio-meta-codecs
kxstudio-meta-restricted-extras
kxstudio-meta-non-free

Install the meta-packages you want just like before (ie, search for the package and click to install, or use in command-line: sudo apt-get install ) See Documentation:Ubuntu:Meta-Packages for a description of these meta-packages.

Note - meta-all recommends restricted extras, and audio recommends audio-plugins.

Step 5 - Install a Kernel

This step was required in my case. And the generic kernel was not enough. I had to install kxstudio-kernel-lowlatency.

Installing a kernel in KXStudio couldn't be easier - just install one of these packages:

kxstudio-kernel-generic
kxstudio-kernel-generic-pae (32bit only)
kxstudio-kernel-lowlatency
kxstudio-kernel-lowlatency-pae (32bit only)
kxstudio-kernel-realtime (10.04 or 12.04)
kxstudio-kernel-realtime-pae (10.04 or 12.04, 32bit only)

The realtime kernels are only available for 10.04 and 12.04. Ubuntu 10.04 uses a 2.6.33 RT kernel and 12.04 uses a 3.2.0 one.

Step 6 - Reboot and update settings

After all this, it's time to reboot. The next time you login, you'll see the KXStudio Welcome Screen to help you update your settings (and maybe the theme too). You should also run 'cadence' and change your JACK settings to your preference. Finally, just re-login again after updating the settings.

Step 7 - Enjoy!

Of course, now it's time to enjoy!

  • Well supported hardware always strictly depends on the kernel... – 71GA Aug 20 '16 at 6:42
3

As of 2017 / 2018 (e.g., Linux kernel 4.X or above), this device works without any special drivers. I'm using it in Arch Linux now without any problem.

However, Focusrite released a new version, the 6i6 2nd Gen, and while that device is Class Compliant and its basic functions work in Linux out of the box, alsa mixer does not work with the 2nd gen 6i6 (yet).

See:

Focusrite Scarlett 6i6 2nd Gen | ardour
https://community.ardour.org/node/14390#comment-48598

Focusrite Scarlett Second Generation - Page 2 - LinuxMusicians
https://linuxmusicians.com/viewtopic.php?t=15810&start=15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.