3

I just switched to tty1, and I'm getting all kinds of output. It all looks like this:

[timestamp] xhci_hcd 0000:00:14.0: ERROR no room on ep ring

It's happening over 100 times per second, every 5 seconds or so, on every tty. Other similar questions say it's happening because of external drives, but the only drive I have mounted is /dev/sda1 (root), as well as a swap partition on /dev/sda5

EDIT: Here's mount as root:

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=1008641,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=808160k,mode=755)
/dev/disk/by-uuid/eb5e28f7-395f-4556-aff4-8c8910a6295c on / type ext4 (rw,relatime,errors=remount-ro,user_xattr,barrier=1,data=ordered)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=4924640k)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfs-fuse-daemon on /home/lucas/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=0,group_id=0)
truecrypt on /tmp/.truecrypt_aux_mnt1 type fuse.truecrypt (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other)
/dev/mapper/truecrypt1 on /media/truecrypt1 type ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)

(Note that this issue started before the truecrypt volume was mounted)

My dmseg has been completely bloated out, nothing but this message.

After rebooting, my dmesg is back to normal. It's way too long to post here, so here's a pastebin link:

dmesg

  • What do you mean those are the only drives mounted? You must have a / mounted somewhere and probably a /home as well. – terdon Sep 1 '13 at 19:00
  • @terdon that's what I'm saying. /dev/sda1 at /, and that's it except for swap – tkbx Sep 1 '13 at 19:00
  • Is this a USB 3.0 device? – slm Sep 1 '13 at 19:29
  • Ah, OK, you meant root, your question said boot hence my comment. I've corrected it. – terdon Sep 1 '13 at 19:39
2

I want my tty

The messages are most likely trying to tell you something. If you're only trying to use the tty1 terminal without all messaging you can temporarily turn it down:

$ dmesg -n #

Where the # is a number such as 1,2,3,...

excerpt from dmesg man page

-n level
          Set the level at which logging of messages is done to the 
          console.  For example, -n 1 prevents all messages, except
          panic messages, from appearing on the console.  All levels of 
          messages are still written to /proc/kmsg, so syslogd(8) can 
          still be used to control exactly where kernel messages appear.
          When the -n option is used, dmesg will not print or clear the
          kernel ring buffer.

Debugging the message

If you're attempting to determine what the source of the messages is then we'lll need more information such as the output form the mount command and also look in the output of the dmesg command for this identical message and provide any lines before and after that seem relevant.

Known issue with USB 3.0 devices?

I found this thread over on Ask Ubuntu titled: ERROR no room on ep ring with USB 3.0 device which sounds like you're issue. Looks to already have a bug opened titled, "ERROR no room on ep ring" fills up syslog and hard disk in minutes, but doesn't appear to have been resolved or even assigned at this point.

  • Updated with mount output. – tkbx Sep 1 '13 at 20:45
  • @tkbx - is this a USB 3.0 device? – slm Sep 1 '13 at 20:46
  • @tkbx - even after a reboot the dmesg is full already? – slm Sep 1 '13 at 20:48
  • no, just SATA (sda1) – tkbx Sep 1 '13 at 20:48
  • I rebooted and it seems to have stopped, but it would be nice to find out what caused this. Adding dmesg to question. – tkbx Sep 1 '13 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.