3

I have looked quite thoroughly for an answer to this question to no avail. I am trying to install Skype on Debian amd64 (with Xfce, which shouldn't make any difference...).

After installing Skype the ''normal'' way

#dpkg --add-architecture i386
#apt-get update
#wget -O skype.deb http://www.skype.com/go/getskype-linux-deb
#dpkg -i skype.deb

some dependencies cannot be satisfied, so I tried:

#apt-get install -f

to fix the broken packages. But this only seems to remove skype. So, something is seriously wrong. In particular these dependencies:

libqt4-dbus:i386
libqt4-network:i386
libqtwebkit4:i386

are not met.

I am, however, unable to install any of them. I end up having to install libdbus-1-3:i386, but it will break libdbus-1-3, which in turn breaks libdbus-1-3:i386.

The following packages have unmet dependencies:
    libdbus-1-3 : Breaks: libdbus-1-3:i386 (!= 1.6.8-1+deb7u1) but 1.6.8-1 is to be installed
    libdbus-1-3:i386 : Breaks: libdbus-1-3 (!= 1.6.8-1) but 1.6.8-1+deb7u1 is to be installed
    skype:i386 : Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
                 Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
                 Depends: libqtwebkit4:i386 (>= 2.1.0~2011week13) but it is not going to be installed

There is one word in German for this situation: zwickenmuehle.

An ideas?

  • Why don't you just fetch the dynamic static package from skype.com? (Which works well) – daisy Aug 30 '13 at 10:04
  • @warl0ck when you say "dynamic static package" you mean the tar.gz package available for download? If so, yes, I have tried that, but the dependencies are still broken, and I still get stuck with same problem. – Horacio Aug 30 '13 at 14:25
  • The common German word for this is "Zwickmühle" ( "Zwickenmühle" seems to be only used in street names, it is not in the common dictionaries. It could be that it is the name of a special mill and is not related to the game as Zwickmühle). – jofel Aug 30 '13 at 15:28
  • @Horacio yes, the tar.gz package – daisy Aug 31 '13 at 0:36
  • It is customary to note the Debian version. Is it stable/testing/unstable? I recently installed the skype 32 bit package on 64 bit wheezy/stable, and didn't encounter these issues. Note that the older 2.2.0.35-1 versions are on skypes server, but skype does not link to them. This is what I currently have installed - it may be an option for you. – Faheem Mitha Sep 1 '13 at 17:40
2

This is common problem in 64 bits for installing Skype

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

Then you may install packages that complained about dependencies, like
sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.

Finally, you should remove the file you just created:

sudo rm /etc/apt/preferences

Now download Skype From Official website(skype.com ) for multi architecture

then open the downloded package from software center then you should able to install skype

1

I just successfully installed skype on my 64bit Linux Mint Debian (which is a Debian in all ways, not based on Ubuntu) by going to http://www.skype.com/en/download-skype/skype-for-linux/downloading/?type=debian32 to download the "multiarch" debian package (saved as skype-debian_4.2.0.11-1_i386.deb) and installing it. The exact steps were almost the same as yours:

sudo dpkg --add-architecture i386 && apt-get update
sudo dpkg -i skype-debian_4.2.0.11-1_i386.deb 

After which I had a working skype. This is the "recommended" method according to https://support.skype.com/en/faq/FA12120/getting-started-with-skype-for-linux#2.2

  • Well, the only thing I find in contrib are actually pidgin plugins for skype. And they require skype to work. Am I looking in the wrong place? – Horacio Aug 30 '13 at 13:23
  • @Horacio no you're not, I just don't know what I'm talking about apparently, my bad. I had skype working happily, uninstalled it so I can reinstall and show you the steps and now I can't install :). I'll update my answer as soon as I manage to get it to work. – terdon Aug 30 '13 at 13:47
  • @Horacio see updated answer. – terdon Aug 30 '13 at 14:06
  • thank you very much. But I have followed that exact same procedure you did, and the dependency problems arose anyway. And it was there where I got stuck. – Horacio Aug 30 '13 at 14:18
  • could it be that I have Debian is not fetching the 32bit files it needs? My sources.list: deb http://ftp.us.debian.org/debian stable main contrib – Horacio Aug 30 '13 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.