1

I'm facing some problems with the CentOS graphical interface.

When I try to reboot the machines, it seems everything okay. I can connect to the machine through ssh from other machine and it has no problem with using it. However, the screen on the actual machine (CentOS 6.2) shows me a black screen after the CentOS logo disappears.

It should show me the login screen but nothing is on the screen.

  • Can anyone know what would be the problem here?
  • Can I try to re-install the graphical interface again? If so, how?
  • use egrep "EE" /var/log/Xorg.0.log and egrep "WW" /var/log/Xorg.0.log Of course you'll get about two lines for each command, Because the given file have comment for WW and EE at top of file, please troubleshoot yourself, It's easy. – PersianGulf Aug 30 '13 at 3:37
  • Is this in a Virtual Machine or Bare metal? If bare metal, what is your graphics adapter? – Tim Aug 30 '13 at 18:58
1

First, you can use ALT-F1, ALT-F2, ... (it might be CTL-ALT-F1, ...) to switch the virtual console using the console keyboard. Screen 1 should always give a text login. If that doesn't work, and you don't see boot messages on the console, there could be a bigger issue to solve.

In order to reconfigure X, try the system-config-display mentioned here:

http://www.centos.org/docs/5/html/Deployment_Guide-en-US/ch-x.html

You can also try the setup command mentioned here:

http://www.centos.org/docs/2/rhl-gsg-en-7.2/s1-q-and-a-xconfig.html

This page is for 7.2, but I believe the commands are the same for 6.2.

The following page shows the command Xorg -configure. I would test it on my CentOS server, but I don't have access right now.

https://www.centos.org/modules/newbb/viewtopic.php?topic_id=38475

It sounds likely that the X-windows setup is not configured right - whether it's the type of display adapter, amount of display memory, or other setting.

| improve this answer | |
  • 1
    Xorg -configure is sufficient for Cent 6.2, 6.3 and 6.4. – Tim Aug 30 '13 at 19:01
  • I just tried Xorg -configure and it complained because I already had another X server running. So, I tried system-config-display, and that seems like a good one to try. – ash Aug 30 '13 at 20:56
  • All links are not valid now! – Sarz Dec 20 '18 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.