3

When I was using squeeze, Qbittorrent was the only bittorrent client installed (I think). Once I had downloaded a torrent file using Chromium it would download to a bar at the bottom of the window, and on clicking it would bring up Qbittorrent.

Now I am using wheezy. I have other bittorrent clients installed, including Transmission and Deluge. Now, when I click a torrent file at the bottom of the Chromium window, it brings up Transmission. How can I configure Chromium to bring up whatever bittorrent client I wish? I assume Debian has some internal preference system for which bittorrent client is chosen, but I have not found any documentation about this.

NOTE: The question Set Transmission as default program when opening magnet links is very similar.

1
  • 1
    In Ubuntu and Chrome, it is via xdg. Seehere for a detailed explanation of what to do to change xdg associations. I hope it is the same in wheezy.
    – vinnief
    Commented Aug 29, 2013 at 22:29

2 Answers 2

4

Chromium uses the default application.

How to find the default application for a given mime type

# general case
xdg-mime query default <mime-type>

# your case
xdg-mime query default application/x-bittorrent
xdg-mime query default x-scheme-handler/magnet

Changing the default application

# general case
xdg-mime default <application.desktop> <mime-type>

# your case
xdg-mime default transmission-gtk.desktop application/x-bittorrent
xdg-mime default transmission-gtk.desktop x-scheme-handler/magnet

Those commands alter the file $HOME/.local/share/applications/mimeapps.list and/or $HOME/.local/share/applications/defaults.list, which means you can also do the change manually.

1
  • Thanks for the answer; I'd not heard of xdg before, and was barely aware of the existence of freedesktop. So, in my case I need to do xdg-mime default qbittorrent.desktop application/x-bittorrent, and xdg-mime default qbittorrent.desktop x-scheme-handler/magnet. I verified that this works. Two followup questions. (1) This file didn't exist originally, of course, so where was the transmission default set? (2) You seem to have the same config file twice separated by and/or. Namely, $HOME/.local/share/applications/mimeapps.list. Commented Aug 30, 2013 at 20:48
1

I do not know of a way something specific to chrome/chromium, but if you are OK with setting what opens torrents system-wide I have an answer.

You can specify which program you wish to have open torrent files by editing the file ~/.local/share/applications/mimeapps.list. Below is the top of that file on my computer where I specified that torrents should be opened with Transmission.

$ head ~/.local/share/applications/mimeapps.list 
[Added Associations]
application/x-bittorrent=transmission-gtk.desktop;
application/octet-stream=gedit.desktop;vim.desktop;
video/quicktime=mplayer.desktop;
video/x-quicktime=mplayer.desktop;
video/vnd.rn-realvideo=mplayer.desktop;
video/x-ms-asf-plugin=mplayer.desktop;
video/x-msvideo=mplayer.desktop;
video/msvideo=mplayer.desktop;
video/x-ms-asf=mplayer.desktop;

The line of interest is application/x-bittorrent=transmission-gtk.desktop;. To use deluge instead, the line would be application/x-bittorrent=deluge.desktop;.

Be sure you add the line under the [Added Associations] header, as there could be other sections in your file.

Once you have done this chrome, as well as other things, will use the specified program to open torrent files.

Reference at freedesktop.org

1
  • Thanks for the helpful response, and the nice link. Unfortunately, I can only accept one answer. :-( Commented Aug 30, 2013 at 20:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .