I'm trying to install these bitmap fonts: http://font.gohu.org/

I downloaded the compressed PCF files and extracted them to /usr/share/fonts, Then ran sudo fc-cache -fv.

The fonts weren't showing up in any program's font options.

I tried the same but with true type fonts; same result.

I tried using ~/.fonts as my font directory; still no change

I tried using Mint's inbuilt font installer (by double clicking on the font file), and it says "Install Failed" when I click on the Install button. I've tried renaming the .pcf.gz files to .pcf but with the same results.

I tried doing all of the above and then rebooting my system and I still can't see the fonts in any programs.

  • Renamed the .pcf.gz files to .pcf? But that doesn't change the nature of the files -- they are still compressed. – Barun Aug 29 '13 at 14:05
  • I also use Mint, and I can't install these fonts, either. I used the Font Viewer to install them (both PCF and TTF), and they don't appear in the GTK font picker. EDIT: when it says it failed, that usually means the font has already been installed. – Wutaz Aug 29 '13 at 15:44

the default config restricts the use of bitmap fonts, that's all.

$ sudo rm /etc/fonts/conf.d/70-no-bitmaps.conf
$ sudo ln -s /etc/fonts/conf.avail/70-yes-bitmaps.conf /etc/fonts/conf.d/70-yes-bitmaps.conf

restart X (i.e. log out and log in again) and you should be good to go :)

(note, however, that not every program can use bitmaps fonts. LibreOffice, for example, can't use them.)


just for the record, and in case it wasn't clear, I'm running Linux Mint 15 64bit as my primary operating system, and I've successfully installed and am using the GohuFonts -- no need to ungzip them, or to use xset.

| improve this answer | |
  • xset removes the need to restart the X server, if one doesn't want to close the session. – peterph Sep 4 '13 at 22:17
  • @peterph -- is that so? thanks, I didn't know that! – simon Sep 5 '13 at 2:14

You need to recreate X server's font list. Either restart your X session (you can also start another one either on different virtual terminal or use a nested server like Xephyr) or simply tell the one running to reindex its font cache:

$ xset fp rehash
| improve this answer | |

On KDE, the fonts I added to ~/.fonts did not show up in programs until I ran fc-cache -f -v. I cannot imagine why. No such problems on GNOME.

| improve this answer | |

Don't forget to uncompress the download.

gunzip filename.pcf.gz
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.