0

I installed Munin and munin-node on Server and httpd was already installed. But after installed when i run the munin-node the Browser gives me this error.

Not Found

The requested URL /munin was not found on this server.

Apache/2.2.3 (Red Hat) Server at 192.168.5.1 Port 80

I checked the /etc/munin.conf file and the path to Html directory is correct.

# Example configuration file for Munin, generated by 'make build'

# The next three variables specifies where the location of the RRD
# databases, the HTML output, and the logs, severally.  They all
# must be writable by the user running munin-cron.
dbdir   /var/lib/munin
htmldir /var/www/munin
logdir  /var/log/munin
rundir  /var/run/munin

And the Permission for /var/www/munin/ are set for munin:munin

/etc/httpd/conf.d/munin.conf

# For SSL-servers
ScriptAlias /munin/cgi/ /var/www/munin/cgi/
#<Directory /var/www/munin/cgi/>
#   Options ExecCGI
#   SSLRequireSSL
#   order deny,allow
#   deny from all
#   AuthType Basic
#   AuthUserFile /site/cfg/passwd
#   AuthGroupFile /site/cfg/group
#   AuthName "munin"
#   require group munin
#   Satisfy Any
#</Directory>
#
Alias /munin/ /var/www/munin/
#<Directory /var/www/munin/>
#   Options None
#   SSLRequireSSL
#   order deny,allow
#   deny from all
#   AuthType Basic
#   AuthUserFile /site/cfg/passwd
#   AuthGroupFile /site/cfg/group
#   AuthName "munin"
#   require group munin
#   Satisfy Any
#</Directory>

Apache Logs

[Sun Sep 01 04:03:12 2013] [notice] Digest: generating secret for digest authentication ...
[Sun Sep 01 04:03:12 2013] [notice] Digest: done
[Sun Sep 01 04:03:12 2013] [notice] Apache/2.2.3 (Red Hat) configured -- resuming normal operations
[Sun Sep 01 11:34:47 2013] [notice] caught SIGTERM, shutting down
[Sun Sep 01 14:50:15 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sun Sep 01 14:50:15 2013] [notice] Digest: generating secret for digest authentication ...
[Sun Sep 01 14:50:15 2013] [notice] Digest: done
[Sun Sep 01 14:50:16 2013] [notice] Apache/2.2.3 (Red Hat) configured -- resuming normal operations
[Sun Sep 01 14:50:18 2013] [notice] caught SIGTERM, shutting down
[Sun Sep 01 14:50:18 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sun Sep 01 14:50:18 2013] [notice] Digest: generating secret for digest authentication ...
[Sun Sep 01 14:50:18 2013] [notice] Digest: done
[Sun Sep 01 14:50:18 2013] [notice] Apache/2.2.3 (Red Hat) configured -- resuming normal operations
[Sun Sep 01 14:50:41 2013] [error] [client 10.20.20.147] File does not exist: /var/www/html/munin
[Sun Sep 01 14:50:41 2013] [error] [client 10.20.20.147] File does not exist: /var/www/html/favicon.ico

After un-commenting some files in /etc/httpd/conf.d/munin.conf

# For SSL-servers
ScriptAlias /munin/cgi/ /var/www/munin/cgi/
<Directory /var/www/munin/cgi/>
   Options ExecCGI
   #SSLRequireSSL
   order deny,allow
#   deny from all
   #deny from none
   allow from all
   AuthType Basic
   AuthUserFile /site/cfg/passwd
   AuthGroupFile /site/cfg/group
   AuthName "munin"
   require group munin
   Satisfy Any
</Directory>
#
Alias /munin/ /var/www/munin/
<Directory /var/www/munin/>
   Options None
   #SSLRequireSSL
   order deny,allow
#   deny from all
   #deny from none
   allow from all
   AuthType Basic
   AuthUserFile /site/cfg/passwd
   AuthGroupFile /site/cfg/group
   AuthName "munin"
   require group munin
   Satisfy Any
</Directory>
  • Did you restart/reload apache? I am guessing it added a site or configuration file to point /munin to something other than /var/www/munin which probably doesn't exist. (or /var/www/html/munin) – Tim Aug 29 '13 at 16:33
  • Yes, I restarted the Apache many many times just waiting for miracle to happen. But I run out of blessings power right now. I added the /etc/httpd/conf.d/munin.conf data in question – OmiPenguin Aug 31 '13 at 7:51
  • If you could add the relevant errors in /var/log/httpd/error_log, it'd probably help. – jsbillings Aug 31 '13 at 14:02
  • added the httpd logs – OmiPenguin Sep 1 '13 at 11:56
1

The HTML and PNG files are actually created, but the permission set on the file is 640 instead of 644, which apache is not able to read. So there is workaround for this. you should be running the munin as

su - munin --shell=/bin/bash munin-cron  

This will update the graphs with 644 permission, and apache will be able to read it.

0

Please add following lines in /etc/httpd/conf/httpd.conf

Alias /munin /var/www/munin
<Directory /var/www/munin>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

save file, remove your whole munin configuration file and restart apache and munin-node.

/etc/init.d/httpd restart
 chkconfig --levels 235 munin-node on
 /etc/init.d/munin-node restart
  • Sorry I was out of city so i couldn't work on it. Now im back. I followed your instructions but it is still not working. I copied the recent change from /etc/httpd/con.f/munin.conf file and pasted in this thread. Please check – OmiPenguin Sep 5 '13 at 8:27
  • Please remove # from #deny from none line. – Ketan Patel Sep 5 '13 at 8:31
  • No man same error "The requested URL /munin was not found on this server.". This time I copied the folder from /var/www/munin/OP to /var/www/html/. Then restarted the httpd and munin-node but again got the same error – OmiPenguin Sep 5 '13 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.