2

Does Oracle support support remote syslog over TLS/SSL on Solaris 11?

I found it can be done with rsyslog, but is rsyslog default on Solaris 11 and if rsyslog is not default, does Oracle support a system with rsyslog (version?) rather than the default Solaris syslog? Anyone experience with this?

1 Answer 1

2

I don't have experience but I have a wiki link from someone who does. The answer is, yes, rsyslog has been supported for a while on Solaris. http://wiki.rsyslog.com/index.php/Solaris

EDIT: It appears that Solaris 11.1 includes (but does not enable) rsyslog by default. That would suggest that they do indeed support this package.

http://www.c0t0d0s0.org/archives/7631-Less-known-Solaris-11.1-features-rsyslog.html

4
  • I know the developers of rsyslog support Solaris, but the big question in an enterprise environment is will Oracle support my Solaris 11 server if I replaced the the standard syslog with rsyslog. And the other part of the question is if perhaps rsyslog is already installed by default (I doubt it, but haven't been able to find a reference).
    – jippie
    Commented Aug 28, 2013 at 17:28
  • Have you tried: ls /etc/init.d|grep rsyslog ? I know it's almost too simple of a question to ask but thought I'd ask just in case.
    – krowe
    Commented Aug 28, 2013 at 17:42
  • I just found information about Solaris 11.1 which says that it is now installed by default but not enabled. This means that it is a safe bet that they support it. c0t0d0s0.org/archives/…
    – krowe
    Commented Aug 28, 2013 at 17:54
  • No I haven't tried that because at the moment I don't have access to a server and my colleagues who do are all early birds ... @Solaris 11.1 interesting find, absolutely. I have to double check with Oracle I guess, I don't like betting in 24×7 enterprise environments. At least it confirms the bits of information I found online.
    – jippie
    Commented Aug 28, 2013 at 18:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .