I have just downloaded the Android SDK for Linux. I am running OpenSuse 12.3. When I try to run Eclipse, there is an error that says that there is no program to run executable files. So, I use the following ways to make the Eclipse program executable.

  1. Right click on the program and open the 'Properties' option to check the 'Allow executing file as program' checkbox. But as soon as I check the box, it gets unchecked and I am not able to run Eclipse.
  2. I tried using the chmod +x command but there was no change.

As requested here is the output of the file eclipse and ldd eclipse command.

gursheel@linux-vfsr$ file eclipse
eclipse: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped
gursheel@linux-vfsr$ ./eclipse
bash: ./eclipse: Permission denied
gursheel@linux-vfsr$ ldd eclipse
ldd: warning: you do not have execution permission for `./eclipse'
/usr/bin/ldd: line 124: ./eclipse: Permission denied
gursheel@linux-vfsr$ chmod +x eclipse
gursheel@linux-vfsr$ ldd eclipse
ldd: warning: you do not have execution permission for `./eclipse'
/usr/bin/ldd: line 124: ./eclipse: Permission denied

Here is the entry in /etc/fsatb

/dev/disk/by-id/ata-HITACHI_HTS725032A9A364_100712PCK304VKKKRWMJ-part7 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-HITACHI_HTS725032A9A364_100712PCK304VKKKRWMJ-part8 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-HITACHI_HTS725032A9A364_100712PCK304VKKKRWMJ-part9 /home                ext4       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

and /proc/mounts Statics is the name of the drive that has the adt folder with eclipse in it.

/dev/sda3 /run/media/gursheel/Statics fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0
/dev/sda3 /var/run/media/gursheel/Statics fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0

How do I make Eclipse executable?

  • 2
    What's your user name and eclipse owner? try to ls -l eclipse_path... if differ, try to chown your_user -R eclipse_path Aug 27, 2013 at 19:24
  • Is that Eclipse executable shell script? Did you try doing bash eclipse from the terminal?
    – Barun
    Aug 27, 2013 at 19:25
  • How did you try to run Eclipse? Copy-paste the command(s) you typed, and any error message. Aug 27, 2013 at 23:15
  • @Gilles Here are the commands. .../Linux/Android/adt-bundle-linux-x86-20130729/eclipse> chmod +x eclipse .../Linux/Android/adt-bundle-linux-x86-20130729/eclipse> ./eclipse bash: ./eclipse: Permission denied
    – fts
    Aug 28, 2013 at 2:51
  • @Barun I tried doing that. There was an error. 'Cannot execute binary file'
    – fts
    Aug 28, 2013 at 2:56

1 Answer 1


As you have already found your answer in the comments from @sendmoreinfo i'll expand on his answer and give you a possible alternative

Your issue was that eclipse was running on a NTFS drive, NTFS doesn't understand executable bits so by default NTFS-3g mounts your partition as no exec.

At this point I can give you a list of answers to the same question you now have which is how do i mount a NTFS drive so that i can execute programs the following links are solutions to this problem

From the third answer we can pull out that you could remount the drive with the following options (adapted to your case)

sudo mount -t ntfs -o rw,auto,user,fmask=0022,dmask=0000 /dev/sda3 /run/media/gursheel/Statics

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .