8

I've looked at the man pages and the configuration files but found nothing (but maybe I'm missing something). I see only many options for autologin.

From a few googles I've read that the KDE version does work this way, but I would like to continue using the GTK version.

update

I still haven't found a solution and sometime I come back to this issue, looking around have seen some screenshots of lightdm-gtk-greeter that support themes and a popup menu for the user list.

I'm surely missing something in the configuration or need to install some package.

I'm using openbox not gnome, below a picture of my poor greeter.

howto make it remember last user and focus to the password?

enter image description here

update 2

I'm using a GNU/Debian/unstable (jessie/sid)

here some details of the installed lightdm*

$ dpkg -l "*lightdm*" | grep ^ii
ii  liblightdm-gobject-1-0 1.10.0-3     i386         simple display manager (gobject library)
ii  lightdm                1.10.0-3     i386         simple display manager
ii  lightdm-gtk-greeter    1.8.4-1      i386         simple display manager (GTK+ greeter)

$ apt-cache show lightdm-gtk-greeter|grep Homepage
Homepage: https://launchpad.net/lightdm-gtk-greeter

and a debug log (launched from desktop eventually I can add the version from /var/log)

$ /usr/sbin/lightdm --test-mode --debug
[+0.00s] DEBUG: Logging to /home/alex/.cache/lightdm/log/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.10.0, UID=1000 PID=477
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/01_debian.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Running in user mode
[+0.00s] DEBUG: Using Xephyr for X servers
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Registered seat module surfaceflinger
[+0.01s] DEBUG: Adding default seat
[+0.01s] DEBUG: Seat: Starting
[+0.01s] DEBUG: Seat: Creating greeter session
[+0.01s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+0.01s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+0.01s] DEBUG: User alex added
[+0.01s] DEBUG: User trustno1 added
[+0.01s] DEBUG: Seat: Creating display server of type x
[+0.01s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
[+0.01s] DEBUG: Seat: Starting local X display
[+0.01s] DEBUG: DisplayServer x-1: Logging to /home/alex/.cache/lightdm/log/x-1.log
[+0.01s] DEBUG: DisplayServer x-1: Writing X server authority to /home/alex/.cache/lightdm/run/root/:1
[+0.06s] DEBUG: DisplayServer x-1: Launching X Server
[+0.08s] DEBUG: Launching process 482: /usr/bin/Xephyr :1 -seat seat0 -auth /home/alex/.cache/lightdm/run/root/:1 -nolisten tcp
[+0.08s] DEBUG: DisplayServer x-1: Waiting for ready signal from X server :1
[+0.08s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.08s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
/bin/rm: impossibile rimuovere "/var/lib/lightdm-data/lightdm": Permesso negato
[+0.16s] DEBUG: Got signal 10 from process 482
[+0.16s] DEBUG: DisplayServer x-1: Got signal from X server :1
[+0.16s] DEBUG: DisplayServer x-1: Connecting to XServer :1
[+0.16s] DEBUG: Seat: Display server ready, starting session authentication
[+0.16s] DEBUG: Session: Not setting XDG_VTNR
[+0.16s] DEBUG: Session pid=487: Started with service 'lightdm-greeter', username 'alex'

** (process:487): WARNING **: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+0.18s] DEBUG: Session pid=487: Authentication complete with return value 0: Success
[+0.18s] DEBUG: Seat: Session authenticated, running command
[+0.18s] DEBUG: Session pid=487: Not setting XDG_VTNR
[+0.18s] DEBUG: Session pid=487: Running command /usr/sbin/lightdm-gtk-greeter
[+0.18s] DEBUG: Creating shared data directory /var/lib/lightdm-data/alex
[+0.18s] DEBUG: Session pid=487: Logging to /home/alex/.cache/lightdm/log/x-1-greeter.log
[+0.26s] DEBUG: Session pid=487: Greeter connected version=1.10.0
[+0.79s] DEBUG: Session pid=487: Greeter start authentication
[+0.79s] DEBUG: Session: Not setting XDG_VTNR
[+0.79s] DEBUG: Session pid=504: Started with service 'lightdm', username '(null)'
[+0.79s] DEBUG: Session pid=504: Got 1 message(s) from PAM
[+0.79s] DEBUG: Session pid=487: Prompt greeter with 1 message(s)
[+3.23s] DEBUG: Got signal 2 from process 0
[+3.23s] DEBUG: Caught Interrupt signal, shutting down
[+3.23s] DEBUG: Stopping display manager
[+3.23s] DEBUG: Seat: Stopping
[+3.23s] DEBUG: Seat: Stopping display server
[+3.23s] DEBUG: Sending signal 15 to process 482
[+3.23s] DEBUG: Seat: Stopping session
[+3.23s] DEBUG: Session pid=487: Sending SIGTERM
[+3.23s] DEBUG: Seat: Stopping session
[+3.23s] DEBUG: Session pid=504: Sending SIGTERM
[+3.23s] DEBUG: Session pid=504: Terminated with signal 2
[+3.23s] DEBUG: Session: Failed during authentication
[+3.23s] DEBUG: Seat: Session stopped
[+3.23s] DEBUG: Session pid=487: Terminated with signal 2
[+3.23s] DEBUG: Seat: Session stopped
[+3.23s] DEBUG: Process 482 exited with return value 0
[+3.23s] DEBUG: DisplayServer x-1: X server stopped
[+3.23s] DEBUG: DisplayServer x-1: Removing X server authority /home/alex/.cache/lightdm/run/root/:1
[+3.23s] DEBUG: Seat: Display server stopped
[+3.23s] DEBUG: Seat: Stopped
[+3.23s] DEBUG: Display manager stopped
[+3.23s] DEBUG: Stopping daemon
[+3.23s] DEBUG: Exiting with return value 0

here the /etc config files

$ grep -v ^# /etc/lightdm/*.conf
/etc/lightdm/keys.conf:[keyring]
/etc/lightdm/lightdm.conf:[LightDM]
/etc/lightdm/lightdm.conf:[SeatDefaults]
/etc/lightdm/lightdm.conf:greeter-session=lightdm-gtk-greeter
/etc/lightdm/lightdm.conf:greeter-hide-users=true
/etc/lightdm/lightdm.conf:greeter-allow-guest=false
/etc/lightdm/lightdm.conf:[XDMCPServer]
/etc/lightdm/lightdm.conf:[VNCServer]
/etc/lightdm/lightdm-gtk-greeter.conf:[greeter]
/etc/lightdm/lightdm-gtk-greeter.conf:background=/usr/share/images/desktop-base/login-background.svg
/etc/lightdm/lightdm-gtk-greeter.conf:theme-name=Adwaita
/etc/lightdm/lightdm-gtk-greeter.conf:xft-antialias=true
/etc/lightdm/lightdm-gtk-greeter.conf:xft-hintstyle=hintfull
/etc/lightdm/lightdm-gtk-greeter.conf:xft-rgba=rgb
/etc/lightdm/lightdm-gtk-greeter.conf:show-indicators=~language;~session;~power
/etc/lightdm/users.conf:[UserAccounts]
/etc/lightdm/users.conf:minimum-uid=500
/etc/lightdm/users.conf:hidden-users=nobody nobody4 noaccess
/etc/lightdm/users.conf:hidden-shells=/bin/false /usr/sbin/nologin

update 3

I've check version 1.1.6-2/stable with no results.

Installed accountsservice.

(in the while lightdm-gtk-greeter dist-upgraded to 1.8.5-1)

below /usr/share/lightdm/lightdm.conf.d/01_debian.conf

commented out are values as coming from the Debian installation, I changed them (but seem they are overwritten by /etc/lightdm/lighdm.conf)

[SeatDefaults]
#greeter-session=lightdm-greeter
#greeter-hide-users=true
greeter-session=lightdm-gtk-greeter
greeter-hide-users=false
session-wrapper=/etc/X11/Xsession

also changed greeter-hide-users in /etc/lightdm/lightdm.conf, the popup menu now appear, it show others..., user alexis bold as if it is the current or default but below the popup there's still the user input text field with focus and empty (I'll update the screenshot and the test/debug log later).

  • Could you clarify please? Do you want to set up auto login? Do you want lightdm to remember the last user? Or the last session? – terdon Aug 24 '13 at 18:29
  • The best would be if the last used user is remembered but a default would be fine, and the focus to the password field so that just the password is needed to login. Currently I've to type the user+password always. – Alex Aug 24 '13 at 18:34
3
+50

Update: (after comments)

Try to modify in /etc/lightdm/lightdm.conf:

 greeter-hide-users=true

in

 greeter-hide-users=false

It's seems it's needed in all lightdm .conf files. It's possible you need to use lightdm-set-defaults [OPTION...] to fix it. The full options available are in the file: /usr/share/doc/lightdm/lightdm.conf.gz (if installed).

update

In Debian is important to set it in the right section [], [SeatDefaults] in /etc/lightdm/lightdm.conf should win, use lightdm --show-config to see changed settings an in which files are (relative to default values)


Original: Maybe you can try to add this ppa
ppa:lightdm-gtk-greeter-team/daily
and install the LightDM GTK+ Greeter 1.6.0.
it seems that it solves automatically your problem you can see here.

I find the ppa on this page of the Launchpad blog posts.

You can download directly from here Good luck.

  • Thank you @Hastur, but I think I'm already using that version even if installed from the official Debian repositories (at least same mainstream) +1 for pointing out that I missed a lot of detailes about the installation, see update 2 – Alex May 8 '14 at 16:45
  • Thank you. From the 1st link you can see it's possible to select via menu the user. You have a more recent version installed. – Hastur May 8 '14 at 17:21
  • Just an idea: try to modify /etc/lightdm/lightdm.conf:greeter-hide-users=true in greeter-hide-users=**false**. – Hastur May 8 '14 at 18:27
  • see update 3, a little step forward even if seem not to solve, but I've more test to do that I cannot do right now, I'll let you know, thank you – Alex May 8 '14 at 20:01
  • yep, the test/debug mode from desktop is messed up, but on real boot it work :) (edit your answer) – Alex May 8 '14 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.