3

What could the problem be? How do I find out what's going on?

EDIT: Hitting f2 when the progress bar is going across the screen shows that booting stops at "Starting atd: [OK]". After it reaches that point, the screen flickers a little bit and it just hangs.

  • The OP was working on this answer when he encounters this problem. @jonderry I think it's better to give a little context to the problem you are having. – phunehehe Mar 8 '11 at 5:35
  • 2
    If things was working properly before then chances are the newly created /etc/X11/xorg.conf is at fault. Try booting into single user mode and deleting the file. – phunehehe Mar 8 '11 at 5:39
  • What drivers did you install? Do you have 'nomodeset' in your GRUB kernel parameters? – jsbillings Mar 8 '11 at 13:44
5

Sounds very much like there is a problem starting X, especially if you were messing around with xorg.conf.

Deleting xorg.conf should solve the problem, also you should check /var/log/Xorg.0.log for errors.

  • You have saved my laptop. – Wok Mar 3 '13 at 21:50
  • @wok: glad to hear that! – nico Mar 4 '13 at 6:18
0

Since people may not be familiar with the grub boot. The below routine would help.

  1. At boot up screen press and hold SHIFT key until boot selection menu appears.
  2. Press a to change the kernel arguments.
  3. Remove quiet splash if any and add single. Keep everything else intact.
  4. Press enter to boot. Now you should be able to log in to the machine

  5. Locate the xorg.conf file and delete it. rm -f /etc/X11/xorg.conf

  6. reboot

Since you didn't save the last boot option, no need to modify at boot menu again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.