5

I have the Mirror Displays enabled on my Linux Mint 15 Cinnamon 64-bit box, which has a GTX 680 graphics card installed with recommended drivers. I selected the top green one in this screenshot.

However, when on the login screen, the display is not mirrored; it's displayed on the primary monitor only.

I really would like to have the WebGL clouds (the flyover one) MDM login screen projected on a 108″ screen before login. Is there any way I could do this?


Edits for updates:

I notice that the Mirror Displays setting is account-specific. Is there a "default" user at the login screen whose settings I could tweak to enable this? I've tried sudo su -l mdm in an attempt to cinnamon-settings the display to mirrored, but sudo su -l mdm has no effect (very strangely): I retain my shell prompt, and a single exit kills the terminal.

  • (xpost Linux Mint Forums) – wchargin Aug 29 '13 at 5:15
  • Which are the "recommended drivers"? – ams Aug 30 '13 at 8:56
  • In Mint, I go to the new Driver Manager, and it asks which drivers I want for the 680. One has the text "(recommended)" in green. – wchargin Aug 30 '13 at 15:07
  • And you chose which driver? – ams Aug 30 '13 at 15:14
  • I chose the driver with the "recommended" text on it. I'm not at the box right now, but it appears that the recommended driver for the 680 is the nvidia-310 driver. I changed it from the default nouveau driver to the recommended driver. – wchargin Aug 30 '13 at 15:26
0

I recently wanted to change the screen resolution in the Ubuntu login screen, and ran across this:

https://askubuntu.com/questions/73804/wrong-login-screen-resolution

Basically, lightdm has a config file, /etc/lightdm/lightdm.conf, and you can use the variable display-setup-script to set up a script that can do whatever you like with the resolution, mirroring, etc.

I don't know what login program Mint uses, but does it have a similar option somewhere? I don't know, but I think the NVidia driver understands xrandr, and if it doesn't it may have it's own CLI configuration tool.

Sorry I can't be more helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.