3

I'm on Crunchbang 11, 64 bit, it is a Debian Wheezy distro.

This morning Openbox isn't loading correctly

   link to screenshot

  • All the programs and shortcuts are working correctly. Conky is loading correctly.
  • The desktop wallpaper isn't loading
  • The menu on top isn't loading, so if I minimize a program, I will not be able to know where it is.

here's autostart, Openbox version 3.5.0-7, display manager is slim. Here's slim.log

  • I tried relogging, i tried restarting crunchbang, the problem persists – Lynob Aug 21 '13 at 12:57
  • Please add your ~/.config/openbox/autostart* and the ~/.config/openbox/enviroment to the question. Also which display manager do you use and which version of Openbox? – Raphael Ahrens Aug 21 '13 at 13:04
  • @RaphaelAhrens here's autostart pastebin.com/ynKgRpM1 openbox version 3.5.0-7 i couldn't find the file called environment... display manager is slim – Lynob Aug 21 '13 at 13:55
  • @Fischer Ahh SLiM good. Now if you could get the /var/log/slim.log then we should have all we need. – Raphael Ahrens Aug 21 '13 at 14:03
  • @RaphaelAhrens I included slim.log in my question, and I'll do what you said in your answer, and reply, thank you! – Lynob Aug 21 '13 at 15:17
2

In your ~/.config/openbox/autostart there are the following lines.

## Group start:
## 1. nitrogen - restores wallpaper
## 2. compositor - start
## 3. sleep - give compositor time to start
## 4. tint2 panel
(\
nitrogen --restore && \
cb-compositor --start && \
sleep 2s && \
tint2 \
) &

This part is most likely the cause for your problems.

nitrogen is responsible for your background, cb-compositor starts the Compton compositor and tint2 is your task bar.

The script above first executes nitrogen to restore the previous background. If this command fails then it will not execute the rest of the script, this behavior is caused by the &&.

Since you said your background isn't set the error is probably caused by nitrogen.

You could test this by removing nitrogen from the autostart file.

Like this

(\
#nitrogen --restore &&
cb-compositor --start && \
sleep 2s && \
tint2 \
) &

Then you need to login again.

If you want the background back then you will need to find out what is wrong with nitrogen. My wild guess would be that it can't find the background picture or something like that.

  • It worked, I think i should open another question "how to fix nitrogen" rather than trying to fix everything in one question, right? I lost the wallpaper as you said, i could use xfce or other window manager if it's impossible to fix – Lynob Aug 21 '13 at 15:32
  • @Fischer Yeah, try to figure out what happens when you run nitrogen --restore in the console and search the web. If you can't figure out what is going on post a new question. If you find out what was wrong you could add a comment to this question, for the case someone has the same problem. – Raphael Ahrens Aug 21 '13 at 15:38
  • nitrogen --restore outputs zsh: command not found: nitrogen – Lynob Aug 21 '13 at 15:45
  • 2
    i don't know why nitrogen was uninstalled!! i installed it and everything worked – Lynob Aug 21 '13 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.