0

OpenBSD installs newer version of gcc as egcc. I am trying to compile some software that requires gcc 4.4+ and can't seem to convince autoconf to use the newer versions of gcc...

I have tried:

# export CC=egcc
# $CC --version
#   egcc (GCC) 4.7.2
#   ...

and

# export CC=/usr/local/bin/egcc
# $CC --version
#   egcc (GCC) 4.7.2
#   ...

I even tried making symlinks to ~/bin and adding that to my PATH:

# cc --version
#   egcc (GCC) 4.7.2
#   ...

# gcc --version
#   egcc (GCC) 4.7.2
#   ...

and also:

# ./configure CC=egcc
# ./configure CC=/usr/local/bin/egcc
# CC=egcc ./configure
# CC=/usr/local/bin/egcc ./configure

But no matter what I still get:

configure: error: Only GCC 4.4 or newer supported

Will someone please show me the error of my ways!

0

Gah, it wanted g++...

# export CXX=eg++ 

Setting the environment variable CXX did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.