1

I tried to install RHEL 5.1 in an i3 processor machine with 2gb ram. So after installation I tried to boot up, but unfortunately the machine got freezed showing Starting udev. I dont know exactly what the reason is. For finding that I rebooted with disabling the quite mode. I was not able to find any problems. I made a lot of googling and found a solution from a forum.

Boot using nosmp. This worked well, but I just want to know that whether is it a good practise, and also will it make any problems.

I will be running Oracle 11g in that particular machine. The machine will be a middleware which lies between the Data Centre and Main server for data synching purpose.

2

Using the 'nosmp' cmdline option probably won't help at all... and it's VERY old information, since the kernel has been autodetecting multiple cores (or just one!) on it's own for a while now.

I'd REALLY recommend using a newer version of ANY Linux distribution. RHEL 5.1 was released in 2007, there've been major changes and improvements, and using something that old is pretty much setting yourself up for headaches later, it's likely to have many vulnerabilities which have been fixed/patched since then... (6 years!!)

RHEL 6.4 was released in February of this year (2013), it would be the best thing if you were going to stick with RHEL. Of course, there's the price.

Fedora is a viable (affordable!) option, same RedHat, just without the prepaid support plan. Besides, you come here first, just like the rest of you guys (I see you lurking!).

Off the cuff list: Slackware, Mint (very popular lately), Ubuntu, Debian (my favorite), CentOS ("Enterprise Quality" they say), OpenSuSE.. I've lost track. They use CentOS last place I worked for all their servers. I use Debian 7 (Jessie!) for all mine at home.

It boils down to this. Obtain a newer release of Linux, whatever flavor you desire, it should work very well. The RHEL 5.1 may not recognize some device in the newer machine which is making udev lock up (although I do recall a problem with udev a few years ago... but it was fixed) (see! new release!)

Now, IF you were to try to boot that system with 'nosmp'... and IF it successfully booted and was 'usable'... you'd be running a multi-core machine with tons of power... off of a single core. That'd be like driving a V8 engined car... but only using 2 cylinders (a V2?)... and wondering why it hasn't got any pickup.

But due to the udev issue you've mentioned, I don't think that 6 year old Linux likes the new devices it found when udev tried to populate /dev. Confused it's little brain.

I'm Ramblin' again...

  • Thanks Mr.Lornix. I faced this problem in one of my client's machine. They can't upgrade it now, if they do, I can't deliver my project within the deadline. Because they need to get permission from their tops and it will take time. So I'm just moving on with nosmp. Thanks again. – Maximin Aug 19 '13 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.